[solved] API 500 Error on /remote/ and Soap Error: Internal Server Error on Roundcube

Discussion in 'Installation/Configuration' started by degoya, Sep 27, 2018.

  1. degoya

    degoya New Member

    i've setup roundcube and installed the ispconfig plugins on latest debian with latest ispconfig.
    when i try one of the plugins in roundcube i get a Soap Error: Internal Server Error.
    ofcorse i've setup all the configs and followed the tutorial and setup the remote user

    So i tried to open the url in the browser and get a 500 error when calling

    When i open https://ispc.xxxxx.de:6622/remote/json.php?client_get i get

    code    "invalid_data"
    message    "The JSON data sent to the api is invalid"
    response    false
    at least a response. My IspConfig interface is also available under https://ispc.xxxxx.de:6622 i've protected it with a let's encrypt cert. 6622 is my custom port.

    why i can't access the remote api? is there anything special i need to do?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Please check if you have the php soap package installed and if not, install it.

    apt-get install php-soap php7.0-soap
  3. degoya

    degoya New Member

    ahh, Thanks Till you saved me again. I've checked if php7.0-soap is installed but not php-soap. after adding php-soap my setup works great.
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

Share This Page