[SOLVED] borg backup not showing backups

Discussion in 'General' started by WolfTongue, Jan 10, 2023.

  1. WolfTongue

    WolfTongue New Member

    Hi there,

    I am using the backup to backup my domains. This is working for all domains fine except for my main domain (which is also the biggest with ~6GB).

    Today I discovered, that my storage was completely filled. It was very surprising, as I have 1TB and mostly only use about 20% of it. Soon I discovered, that the borg backup for my main domain used the other 80%. As I am completely new to borg and also have other backups I did the following:
    • ispconfig: disabled the backups and deleted all
    • shell: removed the /var/backup/web55 folder of the backups
    Then I enabled the backups again and started a backup using the webinterface for MySQL and web-files. There I discovered some strange things an I hope maybe someone can help me with it:
    • the backup of my around 6GB of webfiles was 12GB big
    • ispconfig only shows the very last backup made. In my case I did a web backup and then MySQL backup - so only the MySQL backup was shown (and I only can restore this one)
    • trying to check the backup using "borg info /var/backup/web55/borg_web" shows me 0 backups with 0 size (also for almost all MySQL backups)
    So I think ispconfig and/or borg was not getting rid of old backups as every place was not showing the backups. All other domains seems to work fine.

    Has someone more information or ideas how to fix that?

    Thank you very much

    I was unable to find any logs containing good information. I only got:

    (This error happened for it seems like every domain, just printed one for here.)
    10.01.2023-02:18 - ERROR - Backup of web files for domain domain.tld using path /var/www/clients/client9/web55 failed.
    Di 10. Jan 10:28:48 CET 2023 PHP Warning:  Undefined variable $backup_download_dir in /usr/local/ispconfig/server/lib/classes/backup.inc.php on line 1311
    Di 10. Jan 10:28:48 CET 2023 PHP Deprecated:  is_dir(): Passing null to parameter #1 ($filename) of type string is deprecated in /usr/local/ispconfig/server/lib/classes/backup.inc.php on line 1311
    Di 10. Jan 10:50:01 CET 2023 PHP Warning:  Undefined array key "db_flags" in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 671
    Di 10. Jan 10:50:01 CET 2023 PHP Warning:  Undefined array key 1 in /usr/local/ispconfig/server/lib/classes/cron.d/100-monitor_mem_usage.inc.php on line 79
    Di 10. Jan 10:50:01 CET 2023 PHP Deprecated:  trim(): Passing null to parameter #1 ($string) of type string is deprecated in /usr/local/ispconfig/server/lib/classes/cron.d/100-monitor_mem_usage.inc.php on line 79
    Di 10. Jan 10:51:02 CET 2023 finished server.php.
    Di 10. Jan 10:52:01 CET 2023 finished server.php.
    Di 10. Jan 10:53:01 CET 2023 finished server.php.
    Di 10. Jan 10:54:01 CET 2023 finished server.php.
    Last edited: Jan 10, 2023
  2. WolfTongue

    WolfTongue New Member

    I started it again to see if it is working but it maybe seems to be a borg backup thing because even borg info shows an empty repository - even if it is 34G big:

    root@srv /var/backup/web55 # borg info borg_web/
    Repository ID: 89ac87bdbc9d6f737f941414c6d2606a07b509c507370b86843499ffc82f27b7
    Location: /var/backup/web55/borg_web
    Encrypted: No
    Cache: /root/.cache/borg/89ac87bdbc9d6f737f941414c6d2606a07b509c507370b86843499ffc82f27b7
    Security dir: /root/.config/borg/security/89ac87bdbc9d6f737f941414c6d2606a07b509c507370b86843499ffc82f27b7
                           Original size      Compressed size    Deduplicated size
    All archives:                    0 B                  0 B                  0 B
                           Unique chunks         Total chunks
    Chunk index:                       0                    0
    root@srv /var/backup/web55 # du -sh borg_web/
    34G     borg_web/
  3. WolfTongue

    WolfTongue New Member

    The package "borgbackup" is part of the autoinstaller script. So it was installed and configured by ispconfig. You can check it on your own here: https://git.ispconfig.org/ispconfig...r/lib/os/class.ISPConfigDebianOS.inc.php#L143

    All in all if anyone has some ideas what can be wrong I would be very happy :). I have one more thing I could't figure out, maybe it is connected. Months ago I used the shell users function to be able to connect to my web directory using sFTP. It worked fine till some weeks ago. Since then I was no longer able to connect using sFTP. So I deleted the user which caused a lot of troubles:
    • It moved the whole user folder and renamed it suffixing a "_bak" (or similar, cannot remember in detail). I moved it back to have all my stuff again.
    • Also some folders are still in the users folder like bin, lib, lib64, run, usr, ... (none of them can be removed, they are somehow protected, checked lsattr and chattr but nothing to do here)
    Last edited: Jan 17, 2023
  4. WolfTongue

    WolfTongue New Member

    Ok I was able to solve the issue:
    Something strange happened with jailkit. So I read the ispconfig source code about jailkit to reset the domain jailkit stuff. So I deleted the jailkit folders in there, reset it in the database and tried to regenerate it. Now I got a different message about "client9" has wrong permissions - needs to be "root:root". So I modified those permissions back to "root:root". After that the ssh jailkit worked fine again.

    Also the backup now works. So it was ether a permission problem of "client9" folder or of the leftovers of the jailkit folders. (It works for now, but I am going to monitor the backup in the next weeks.)

    At the moment I have no idea why the client permission was not on "root:root". But now I am happy to be able to use everything again. But one word to all who want to do the same: modifying files, folders or database is very dangerouse. You should not do that without knowledge about how it is working or should be done!
    Last edited: Jan 18, 2023
    till and ahrasis like this.
  5. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Happened to me some times. :)
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Never seen that on any server yet, so I have no Idea how you got this permission to change that way.
  7. WolfTongue

    WolfTongue New Member

    I think it is not an ispconfig error - more a personal one o_O
  8. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Yes. That's what I mean.

Share This Page