[SOLVED] Cannot login to ISPConfig admin panel

Discussion in 'Installation/Configuration' started by zenny, Nov 26, 2016.

  1. zenny

    zenny Member


    The control panel went blank with an error after an upgrade in debian7 though all sites were working as described here: https://www.howtoforge.com/communit...e-after-upgrading-to-ispconfig-3-1-1p1.74818/

    Therefore, I created a jessie machine and installed using the auto-installer from servisys which went alright. Then I used the script at https://github.com/xavidp/bashscripts/blob/master/migrateispconfig.sh to migrate with necessary changes related to nginx. There were some rsync errors with some huge files to transfer, yet the sites worked as it should, except the ISPConfig admin panel didn't allow to log in.

    However, the ISPConfig admin panel got open without ISPConfig logo on top (see attachment), but the admin user cannot access to:

    1. First, I tried to setup a new admin password to default one as described at http://www.faqforge.com/linux/contr...et-the-administrator-password-in-ispconfig-3/

    because /var/log/nginx/error.log shows:

    and this bug reports says so, too: https://git.ispconfig.org/ispconfig/ispconfig3/issues/2434

    Yet, that didn't work.

    2. Second, I tried to follow @till as described here: https://www.howtoforge.com/community/threads/cannot-login-to-ispconfig.56977/

    No luck!

    3. Then I followed something advised here: http://superuser.com/questions/3490...-login-since-resetting-my-mysql-root-password

    No luck either!? :(

    4. Checked with the /usr/local/ispconfig/server/lib/mysql_clientdb.conf and the credentials were as it should.

    5. I also re-updated manually ISPConfig3 if that can make any difference, but things remains the same! :-(

    6. Cleared browser cache as advised at https://www.howtoforge.com/community/threads/after-upgrade-admin-password-no-longer-works.74786/ but without a luck!

    Where did it go wrong? Really whining me! Inputs appreciated!

    Mandatory htf_report follows:


    Attached Files:

    Last edited: Nov 27, 2016
  2. zenny

    zenny Member

    SOLVED. :D by copying the ispconfig mysql password in /usr/local/ispconfig/{server interface}/lib/config.inc.php from the old server to the new one.

    It struck me when 'ispconfig' user could not connect to the 'dbispconfig' DB with the password.

    REASON: The ISPConfig upgrade/installation script generated a new password for 'ispconfig' DB user every time.

Share This Page