[SOLVED] Can't create new site

Discussion in 'General' started by edooze, Nov 18, 2015.

  1. edooze

    edooze Member

    Hi guys, when I set up a new user and try to create a site, I get this when clicking away from the options page:



    What am I doing wrong? The last thing I did was install the DKIM patch from http://blog.schaal-24.de/ispconfig/ispconfig-dkim-patch/?lang=en - which shouldn't be a problem. No existing sites are causing problems.

    Not sure if this is related, but I also can't delete a limits template I've created. It says it's assigned to a customer. It is not.

    Also, there may be a permissions issue with /var/lib/amavis (and children), however I have reset them to root:root & 750 (and this should only affect e-mail, right?)

    Any help appreciated!
  2. florian030

    florian030 Well-Known Member HowtoForge Supporter

    the patch does not affect web-sites.

    just make sure, that you defined the path for the dkim-keys (but this is related to mail and to web)
  3. edooze

    edooze Member

    Thanks, Florian, let me just say you make one awesome product. Thanks.

    I've checked, and set up the dkim properly (including the directory) - is there anything else it could be?

    I notice the client folder in /var/www/clients/ are owned by root:root - should they be owned by the client?
  4. florian030

    florian030 Well-Known Member HowtoForge Supporter

    don´t mix-up dkim and web-sites.... you may see an error like "unable to write to dkim-dir". this is a known bug.

    the clients-dir is always owned by root
  5. edooze

    edooze Member

    I have checked, and dkim-dir is set correctly. When I click on the 'web' tab, I get the following. Not sure what has happened, is there a way to restore functionality?

  6. edooze

    edooze Member

    I have rolled back to a previous backup - this was far prior to editing DKIM. In fact, it was prior to editing the directive snippet also. Interesting.
  7. edooze

    edooze Member

  8. edooze

    edooze Member

    I managed to dig up a copy of the vanilla server I built two years ago. I logged in to the ispconfig mysql database with phpmyadmin, opened the record at dbispconfig -> server and re-added [web] (AND all the contents) to the "config" field in the location they should have been. Everything else seemed to be there.

    Now the only error left is documentroot_error_empty - which would appear to be a permission issue (possibly unable to create docroot?) as it doesn't happen with any of the sites that were created prior to this error - but I'm just guessing at this stage.

    Any external help appreciated, otherwise I'll keep trying to track it down.
  9. edooze

    edooze Member

    I deleted and recreated the sites and users after this MySQL change, and all is well with the world again. Very odd, but maybe someone can look into why this information disappeared in the first place.

    I run an apache server. Interestingly, when I tried to copy the field values between servers, it said I had not populated the nginx options and was unable to save it, hence i had to use the workaround.

    Hope this helps someone in the future, it was a sh*tter of a job for me.

Share This Page