SOLVED! ERROR 404 - Not Found! after all steps controled and achieved...!

Discussion in 'Installation/Configuration' started by Keoz, Nov 18, 2016.

  1. Keoz

    Keoz Member


    My ISP Config3 was installed with lamp on remote server running apache and Ubuntu 16.04 LTS :

    I have created 2 websites from shell command, and created them afterwards in ISP Config3 from where their domain name links get them displayed through URLs temporary delivered from a different server....

    But for the server with ISP Config3 installed, instead of retuning "INDEX OF / WEBSITE.COM, webrowsers returns for both sites the same rich html ISP Config3 404 ERROR MESSAGE when I try to connect them with
    http://servername/ :

    ERROR 404 - Not Found!
    The following error occurred:
    The requested URL was not found on this server.
    Please check the URL or contact the webmaster.

    Why that ?

    Nevetherless I made all these verifications :
    Websites files in /etc/apache2/sites-available/ are well configured (.conf)
    The demo page is displayed correctly with message “Welcome to your website!“
    Default file “000-default.conf" has been disabled (a2dissite)
    Shell command “locate“ finds repositories and files for both sites
    Websites have been enabled (a2ensite) and apache was reloaded and restarted
    VirtualHosts files are apparently set correctly like :

    <VirtualHost *:80>
    ServerAdmin [email protected]
    DocumentRoot /var/www/html/

    The ERROR page is still showing with or without new adds (databse, domain, dns zone) in ISP Config.

    Should someone know how to fix this, I would appreciate assistance !

  2. Keoz

    Keoz Member

    I have solved the probleme !
    It was only about changing HTTP to HTTPS in the website URL



Share This Page