Discussion in 'Installation/Configuration' started by JasonMacer, Mar 16, 2024.

  1. JasonMacer

    JasonMacer New Member

    As the title says, I am trying to use the SOAP API. Specifically I am trying to activate the ispconfig3 roundcube plugins using the install instructions github for w2c/ispconfig3_roundcube/wiki/Installation and the troubleshooting instructions on github w2c/ispconfig3_roundcube/wiki/Troubleshooting---FAQ).

    Server setup is as follows:
    • CentOS 7.9
    • PHP 8.1.27 (upgraded from 7.4)
    • ISPConfig 3 version 3.2.11p2
    • Roundcube version 1.6.6
    In following the instructions above i have created a user in System -> Remote Users with the following configurations:
    • Remote Access (Checked)
    • Remote Access IPs / Hostnames (Blank)
    • Server functions (Checked)
    • Client functions (Checked)
    • Mail user functions (Checked)
    • Mail alias functions (Checked)
    • Mail forward functions (Checked)
    • Mail spamfilter user functions (Checked)
    • Mail spamfilter policy functions (Checked)
    • Mail fetchmail functions (Checked)
    • Mail spamfilter whitelist functions (Checked)
    • Mail spamfilter blacklist functions (Checked)
    • Mail user filter functions (Checked)
    My config file for the ispconfig3_account plugin is as follows:
    $config['identity_limit'] = false;
    $config['remote_soap_user'] = '<REDACTED>';
    $config['remote_soap_pass'] = '<REDACTED>';
    $config['soap_url'] = 'https://<REDACTED>:8080/remote/';
    $config['soap_validate_cert'] = false;​
    I did set the soap_calidate_cert to "false" as the mail server is using a self signed certificate, and I have verified that I am using the correct username and password combination.

    Inside roundcube when you access the "account" section each page gives an error "Soap Error: Could not connect to host", and when i attempt to visit the soap url in a browser i get "ERR_CONNECTION_REFUSED". I am trying the following urls:
    1. http domain :8080/remote/index.php => returns ERR_CONNECTION_REFUSED
    2. http domain :8080/remote/ => returns ERR_CONNECTION_REFUSED
    3. https domain :8080/remote/index.php => returns ERR_CONNECTION_REFUSED
    4. https domain :8080/remote/ => returns ERR_CONNECTION_REFUSED
    When i run [user@host ~]# netstat -tulpn | grep ':8080' there are no results; however, 8081 has httpd listening to it. So I went back to the browser and this is what I got:
    1. https domain :8081/remote/remote.index.php => returns The requested URL /remote/index.php was not found on this server
    2. https domain :8081/remote/remote/ => returns The requested URL /remote/ was not found on this server
    3. http domain :8081/remote/remote/index.php => returns ERR_EMPTY RESPONSE
    4. http domain :8081/remote/remote/ => returns ERR_EMPTY RESPONSE
    I have been running this server for quite some time, and i have recently upgraded the ISPConfig 3 version and the PHP versions. Did I somehow change the ISPConfig3 SOAP settings?

    Thanks in advance!
  2. JasonMacer

    JasonMacer New Member

    Okay, so need to mark this as complete as I figured out what happened and why it was not working.

    During my initial configuration of ISPConfig 3, I changed the default port used to access the admin section. I cannot find anything, ANYWHERE, which states that this is also the port used for SOAP API access.

    That might be something nice to include in the installation howto configurations. I'll probably shoot emails to some of those that I find.

    Sorry to bother!
  3. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Do that by editing the thread title to start with[SOLVED]. As chreator of this thread, you can see "Thread Tools" button at top right of window, it's a dropdown which has "Edit Title" action.
  4. JasonMacer

    JasonMacer New Member

    Thanks @Taleman.
    That option wasn't showing up until I deactivated "Brave Shields." It looks like that was breaking some of the sites scripts as it appears to be blocking 52 tracking and ad scripts on the site. I temporary suspended them to make the changes then re-enabled them afterwards. I've also reported that this site was not functioning correctly to brave. Maybe they will fix it. Who knows.
    Anyway, topic updated.
    Thanks again!

Share This Page