[SOLVED] ISPConfig Migration Toolkit : Fatal error mysql root password

Discussion in 'Installation/Configuration' started by Babavoss, Jun 4, 2024.

  1. Babavoss

    Babavoss New Member

    Hi together,
    it's the first time I try to use the ISPConfig Migration Toolkit in dry mode
    Source: ISPConfig3.2.11p1 on Debian 11.9
    Target: ISPConfig3.2.11p2 on Debian 12.5

    It results in the following error after asking for the outgoing source IP:

    Fatal error: Uncaught mysqli_sql_exception: Access denied for user 'root'@'localhost' (using password: YES) in /root/migration/v81/migrate.php:615
    Stack trace:
    #0 /root/migration/v81/migrate.php(615): mysqli_connect('localhost', 'root', '..........')
    #1 {main}
    thrown in /root/migration/v81/migrate.php on line 615

    I don't know this password, where can I set the correct one?

    Thanks for helping me out.
    Have a good day and
    Kind regards
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Seems as if you changed root password in mysql after you installed ISPConfig but forgot to tell ISPConfig about that change by setting the new root password in ISPConfig.

  3. Babavoss

    Babavoss New Member

    I've take a look in that file, the password in there is the correct one from the user root.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    According to the error message you posted, this password does not work. Test it with:

    mysql -h localhost -u root -p

    and then enter the password when requested. Test it on old and new server.
  5. Babavoss

    Babavoss New Member

    I've tested this already on both machines. The logins as root are good. The password in the error message which is censored at the end is unknown to me, and the linked config file also includes the correct password.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Check the password in the file /etc/mysql/debian.cnf
  7. Babavoss

    Babavoss New Member

    Thanks, the unknown password is in there. However just changing the file and killing the processes does not work. So I've changed the password back to its original, and now the migration tool has no problems.
    till likes this.
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Alternatively, you could have deleted the whole migration tool folder and downloaded + unpacked it again. Most likely, the tool cached the password there.
    Babavoss likes this.

Share This Page