[solved] ISPconfig3 Multiserver slave not processing jobs

Discussion in 'General' started by degoya, Mar 28, 2019.

  1. degoya

    degoya New Member

    Running ISPconfig 3.1.1 on Debian 9

    After a crash i had to resetup the master server of a multiserver setup with a 1 day old backup.
    Meanwhile there have been some small settings made, but i could redo them.

    now i got the problem that the jobs are not synced to one (file,db and web) of the servers in the multiserver setup.
    all other servers work without problems only one keeps the jobs in the queue. Everything worked fine before i recovered the master.

    i followed https://www.faqforge.com/linux/debugging-ispconfig-3-server-actions-in-case-of-a-failure/

    and got this as result of the call of /usr/local/ispconfig/server/server.sh on the failing slave server

    28.03.2019-18:42 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    28.03.2019-18:42 - DEBUG - Remove Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
    So it seems there are no errors. But the job's are not processed

    i also tried to connect to the master db from the slave commandline without any problems.
    after the debug mode is available on the slave i presume that the slave can connect to the master db

    i've commented out and in the server in the crontab and restarted the cron and even the complete server (master and affected slave)

    there where no errors in syslog or cronlog.

    i've checked in the master DB if "updated" from server table is smaller than datalog_id from sys_datalog table
    For testing i've set the "updated" to to the highest id in sys_datalog, the red bubble disapeared, when i do new changes they are again not populated to the server.

    does anyone got a idea what i could do?
    Last edited: Mar 29, 2019
  2. degoya

    degoya New Member

    i've found out that there is also a updated column in the slave that had a different value than the recovered server after changing it to the same value like the master everything worked fine again
    till likes this.

Share This Page