[Solved] Jobs stuck after password for stats was set

Discussion in 'Installation/Configuration' started by Joel B, Sep 7, 2018.

  1. Joel B

    Joel B New Member

    Just generated a password for a domain in my ISPconfig thats been working great until now.

    [Fri Sep 07 21:18:23.545354 2018] [authn_file:error] [pid 5110] (2)No such file or directory: [client yy.xx.58.138:6013] AH01620: Could not open password file: /var/www/clients/client1/web2/web/stats/.htpasswd_stats

    Before this no password was set and there were no .htpasswd_stats file when I looked in the dir after the job got stuck. So I created the .htpasswd_stats file but no luck, deleted it and touched it but the job queue is still stuck, tried to enable debugging in frontend but that's get stuck as well.

    Any suggestions for a fix? :)

  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Does that file exist now?
    If it is there, it may be wrong owner or permissions prevent it being opened or read.
    What job is stuck?
  3. Joel B

    Joel B New Member

    Thanks for the reply Taleman!
    Files exists and correct user/pw works while visiting the stats page, and I have tried all versions of owner/group with no luck with the jobqueue, so tried to dig a bit and while running server.sh then I get as below, but it looks like this error already existed before I

    10.09.2018-07:50 - DEBUG - Calling function 'check_phpini_changes' from plugin 'webserver_plugin' raised by action 'server_plugins_loaded'.
    PHP Fatal error: Uncaught Error: Call to undefined function mb_detect_encoding() in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php:445
    Stack trace:
    #0 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(160): db->escape('Calling functio...')
    #1 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(224): db->_build_query_string('INSERT INTO sys...', 1, 0, 'Calling functio...')
    #2 /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php(263): db->_query('INSERT INTO sys...', 1, 0, 'Calling functio...')
    #3 /usr/local/ispconfig/server/lib/app.inc.php(165): db->query('INSERT INTO sys...', 1, 0, 'Calling functio...')
    #4 /usr/local/ispconfig/server/lib/classes/plugins.inc.php(155): app->log('Calling functio...', 0)
    #5 /usr/local/ispconfig/server/server.php(174): plugins->raiseAction('server_plugins_...', '')
    #6 {main}
    thrown in /usr/local/ispconfig/server/lib/classes/db_mysql.inc.php on line 445

    Checked common dependencies after googleing the error but all php-stuff I came across is installed (like: php7.0-mbstring, php7.0-dom etc)

  4. till

    till Super Moderator Staff Member ISPConfig Developer

    php-mbstring is missing in the PHP version that is used to run the server script. Please run these commands and post the output:

    which php


    php --version
  5. Joel B

    Joel B New Member

    which php
    # php --version
    PHP 7.2.9-1+ubuntu16.04.1+deb.sury.org+1 (cli) (built: Aug 19 2018 07:16:12) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    with Zend OPcache v7.2.9-1+ubuntu16.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies

    Indeed sir, you were very right! iIstalled php-mbstring and it started propagating the changes! Don't know if I missed this package before or if it somehow managed to get lost in some upgrades before.

    Thanks a bunch for the answer :)
    till likes this.

Share This Page