[Solved] "magick: no decode delegate for this image format `JPG'"

Discussion in 'Installation/Configuration' started by Emsanator, Nov 11, 2022.

  1. Emsanator

    Emsanator Member

    Hello ISPconfiger,

    I entered the following command to have multiple images as a single image but got an error. I think it's giving errors because of Imagemagick Path but I'm not sure. For this reason, I wanted to completely delete Imagemagick and reinstall it, but I wanted to ask the forum because I might unintentionally damage the ISPconfig settings.

    How can I bypass this error?

    Thank you.

    web53@serve:/var/.../storage$ magick /var/.../storage/imagesTemp/*.png -append /var/.../storage/all.png
    magick: no decode delegate for this image format `PNG' @ error/constitute.c/ReadImage/737.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    This issue s not related to imagemagick path, the error tells you that imagemagick does not understand the image format as it lacks a decoder for it. Are you running this inside a chroot jailed user account? if yes, you must probably add some Linux system libraries to the jail to enable imagemagick to decode png files. or use an unjailed account.
  3. Emsanator

    Emsanator Member

    I am trying to execute the command via the user account. I think I need to install the ImageMagick plugins you mentioned. I don't know what these names "Linux system libraries" are so does removing the server and reinstalling ImageMagick will affect ISPconfig?

    root@serve:~# convert -list configure
    Path: /usr/local/lib/ImageMagick-7.1.0//config-Q16HDRI/configure.xml

    Name Value
    CC gcc
    CFLAGS -fopenmp -Wall -g -O2 -mtune=amdfam10 -fexceptions -pthread -DMAGICKCORE_HDRI_ENABLE=1 -DMAGICKCORE_QUANTUM_DEPTH=16
    CODER_PATH /usr/local/lib/ImageMagick-7.1.0/modules-Q16HDRI/coders
    CONFIGURE ./configure
    CONFIGURE_PATH /usr/local/etc/ImageMagick-7/
    COPYRIGHT Copyright (C) 1999-2021 ImageMagick Studio LLC
    CPPFLAGS -I/usr/local/include/ImageMagick-7
    CXX g++
    CXXFLAGS -pthread
    DISTCHECK_CONFIG_FLAGS --disable-deprecated --with-quantum-depth=16 --with-jemalloc=no --with-umem=no --with-autotrace=no --with-fftw=no --with-flif=no --with-gslib=no --with-fontpath= --with-rsvg=no --with-wmf=no --with-perl=no
    DOCUMENTATION_PATH /usr/local/share/doc/ImageMagick-7
    EXEC-PREFIX /usr/local
    EXECUTABLE_PATH /usr/local/bin
    FILTER_PATH /usr/local/lib/ImageMagick-7.1.0/modules-Q16HDRI/filters
    GIT_REVISION 19841
    HOST x86_64-pc-linux-gnu
    INCLUDE_PATH /usr/local/include/ImageMagick-7
    LDFLAGS -L/usr/local/lib
    LIB_VERSION 0x710
    LIBRARY_PATH /usr/local/lib/ImageMagick-7.1.0
    LIBS -lm -lpthread -lgomp
    NAME ImageMagick
    PREFIX /usr/local
    QuantumDepth 16
    RELEASE_DATE 2022-03-27
    SHARE_PATH /usr/local/share/ImageMagick-7
    SHAREARCH_PATH /usr/local/lib/ImageMagick-7.1.0/config-Q16HDRI
    TARGET_CPU x86_64
    TARGET_OS linux-gnu
    VERSION 7.1.0
    WEBSITE https://imagemagick.org

    Path: [built-in]

    Name Value
    FEATURES Cipher DPC HDRI OpenMP(4.5)
    NAME ImageMagick
    QuantumDepth Q16
  4. pyte

    pyte Well-Known Member HowtoForge Supporter

    You need to compile imagemagick with PNG support. There is a project on github that handels all the steps for you, it's ubuntu/debian only atm.

    Emsanator likes this.
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    and such an account can be jailed or unjailed, depending on the settings you have chosen. ImageMagick normally has png support builtin, so I guess there is no need to compile it. As you don't seem to be very Linux savvy I would recommend creating an unjailed shell user instead, this is a bit less secure, but probably the easier way for you to solve the issue.

    It will not affect ISPConfig, but I doubt that it will solve your problem.
  6. pyte

    pyte Well-Known Member HowtoForge Supporter

    Ohh it is not working for a jailkit user not everyone, that makes more sense then :^)
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    That's at least my best guess, that imagemagick command has been copied to the jail, but some of the Linux libs for image conversion that imagemagick might depend on are absent in the jail.
  8. Emsanator

    Emsanator Member

    @till & @pyte thank you for your valuable help. I solved the problem with the repo on the GitHub link provided by @pyte.
  9. pyte

    pyte Well-Known Member HowtoForge Supporter

    Now i'm curious what distro are you using? Ubuntu?
  10. Emsanator

    Emsanator Member

    Debian 10

Share This Page