[SOLVED] Multiserver - missing cron per website and web backup

Discussion in 'General' started by c3n, Jun 8, 2017.

  1. c3n

    c3n Member

    My setup is multiserver latest ISPconfig, debian 8.
    htf-common-issues.php --> nothing wrong on problematic ISP
    running manually server.sh --> nothing wrong on problematic ISP
    main.com --> panel [VPS1]
    domain2.com --> [VPS2 - client2] with ISPconf connected and managed from main.com
    domain3.com--> [VPS3 - client3] with ISPconf connected and managed from main.com​
    I got about 20 VPS servers running in KVM multiserver ISPconfig, one client = one VPS -- everything works like a charm... but few days ago I noticed strange behaviour... propably the problem comes because I changed the client login for ISPconfig user pinned to VPS server and when I add from main.com ISP PANEL new website, mysql, domains, mail etc. everything is OK and appears on dedicated VPS but two things are missing:
    1) when I setup backup website only MYSQL is backuped and web backup is missing... its clean install without any modifications so chmod/chown is OK. I tried to change root and zip user.
    2) when I setup cron job for website it is shown in main.com panel as pinned to domain2.com [VPS2] but it is not triggered on that server, its missing in /etc/cron.d
    so most of settings made for domain/website in IPS panel appears on serwer domain2.com except cron and web backup
    This problem affects my 4 servers and I double-checked server config, cron settings so they are the same as on servers where web backup is OK and cron for web is OK. There is 30% free space...
    I think that in 3 servers it can be connected with user login change - because it is only thing that was changed...
    On one server nothing changed.
    Any thoughts how to fix it?
    Last edited: Jun 8, 2017
  2. c3n

    c3n Member

    source of the problem is changing user login. After creating server I made for example
    somelogin01 and connect this user with server via limit settings
    after several months I change somelogin01 to differentlogin12
    Now I;ve read a lot about the problem but dont know how to fix it correctly without removing user and recreating it again with all websites on that server. I run:
    'www-data' is a member of the 'client13' group in /etc/group but not in /etc/gshadow
    can I fix it manually without breaking ISPconfig setup? It is huge problem for me because I cannot setup cron jobs for large websites and also cannot make automatic backup using ISPconfig tool.
  3. c3n

    c3n Member

    on multiserver setup check dbispconfig on main and slave and You will see that WEB_DOMAIN table on main server has all records for server / user and slave does not or records differ from main. CREATE BACKUP before... on slave and master. In my case I had to export records dbispconfig/WEB_DOMAIN for that client from MAIN server (on my setup client = one dedicated VPS)... You can sort them via sys_groupid
    delete broken records on SLAVE and import records.
    You will see that all broken cronjobs or missing backup will work correctly.

Share This Page