[SOLVED] MySql crashed on upgrade from 10.04 to 12.04 - Ubuntu

Discussion in 'Installation/Configuration' started by bhasina, Jul 9, 2012.

  1. bhasina

    bhasina New Member


    I recently upgraded my server from Ubuntu 10.04 to 12.04 LTS running Ispconfig

    Everything went smooth except my MySQL wouldn't work now. I keep getting the following error:

    ERROR 1524 (HY000): Plugin 'none' is not loaded
    I get the above error whenever I do

    mysql status
    I have tried to do a fresh install of MySQL but it continues to give the same error. I cannot login to the server using

    mysql -u root -p
    as it gives the same error.

    Any help will be greatly appreciated.
    Last edited: Jul 9, 2012
  2. TiTex

    TiTex Member

    have you tried to run the mysql_upgrade script after upgrading ?
    sudo mysql_upgrade --password=root-password-here
    if doesn't let you run the script , start mysql server with --skip-grant-tables
    sudo /usr/sbin/mysqld --skip-grant-tables &
    and after that
    sudo mysql_upgrade --force
    i think your problem is a bug discussed here http://bugs.mysql.com/bug.php?id=60432
    Last edited: Jul 10, 2012
  3. bhasina

    bhasina New Member

    Thanks TiTEX but none of it worked. I ended up completely removing mysql with purge and reinstalling. Also had to remove the user data (mysql folder in the data). All up and working now!
  4. bhasina

    bhasina New Member

    Is there a way to mark this solved?
  5. falko

    falko Super Moderator ISPConfig Developer

    I've added [SOLVED] to the thread title. :)
  6. makoshark

    makoshark New Member

    solved without sharing

    I have tried to purge and reinstall and still have error 1524 Plugin 'none' is not loaded when trying to connect. the last post did not share what and were the files are to delete so I am lost

Share This Page