[SOLVED] no access to control panel (port 81)

Discussion in 'Installation/Configuration' started by atrias, Jun 20, 2008.

  1. atrias

    atrias New Member


    I'm having problems accessing https://my.domain:81 as well as https://<ip>:81

    firefox 3 gives error:
    I am running CentOS 5.1 (but i also plan to install on centos 5.2 in 3 days that it will be out :) )
    i followed this HOWTO to setup the system and then the installation procedure described in ISPconfig webpage

    I followed the faq in this page but no solution

    with netstat -tapn among others i get

    proftpd works ok from another PC in the LAN (at least it gives me a user/pass prompt)

    firewall is off

    by the way (maybe it is relevant) the logs in:
    are the httpd logs of the web pages and not the control panel (port 81) correct?

    so the logs in:
    should be the logs of the control panel (port 81)

    I'm asking because in the second path access_log and ssl_request_log are zero size and have not been touched since the day of ispconfig install

    any hints would be greatly appreciated!
    i haven't even seen yet how the control panel looks like! :eek:
  2. falko

    falko Super Moderator Howtoforge Staff

  3. atrias

    atrias New Member

    thank you for your quick reply

    i have already done this (forgot to mention it)

    openssl genrsa -des3 -passout pass:yourpassword -out /root/ispconfig/httpd/conf/ssl.key/server.key2 1024
    openssl req -new -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.csr/server.csr -days 365
    openssl req -x509 -passin pass:yourpassword -passout pass:yourpassword -key /root/ispconfig/httpd/conf/ssl.key/server.key2 -in /root/ispconfig/httpd/conf/ssl.csr/server.csr -out /root/ispconfig/httpd/conf/ssl.crt/server.crt -days 365
    openssl rsa -passin pass:yourpassword -in /root/ispconfig/httpd/conf/ssl.key/server.key2 -out /root/ispconfig/httpd/conf/ssl.key/server.key
    chmod 400 /root/ispconfig/httpd/conf/ssl.key/server.key
    any other suggestions please?
  4. matzhu

    matzhu New Member


    I was about to post saying that I had the same problem when I discovered that I could access my server through port 81 from a remote connection. I disabled my firewall (Comodo) and voila: connection. I then added port 81 to Comodo's port sets and all is well.

    I went ahead and posted this mainly because it seems that something changed with Comodo since yesterday as I was able to access through 81 at that time. I assume it's an update as I have not touched any settings in Comodo since the problem started.
  5. falko

    falko Super Moderator Howtoforge Staff

    Did you accept the default values, or did you type in your own values? If you type in a wrong value, the certificate will not work.
  6. atrias

    atrias New Member

    i am also using this f$%^$%^ing firewall!!
    (sorry for my language!!!)
    added port 81 to http port set and all is ok now!
    thnk you mate! :D:D

    also thnk you falko for your time and help! :)
    i think that if it was something related to the certificate i would get an error indicating this but the browser would allow me to continue to the site
    that is what happens to every site i have visited with an ssl certificate error (expired, self signed, wrong domain, etc)
  7. atrias

    atrias New Member

    please somebody change the subject of the thread to resolved also stating that COMODO firewall has an issue with port 81!!

Share This Page