[SOLVED]Php issue on fresh install

Discussion in 'ISPConfig 3 Priority Support' started by SebUndefiend, Nov 13, 2016.

  1. SebUndefiend

    SebUndefiend New Member

    After a fresh install of Ubuntu 16.04 and an installation of ISPConfig 3.1 by following this tutorial , php is not correctly set (I guess).
    Actually, php-fpm does not work, it shows me an Error 500 with a simple phpinfo() or a fresh install of WP...

    I checked the website log under /var/www/MyWebsite.fr/log/error.log and it shows (IP and domain hidden) :
    [Sun Nov 13 16:18:03.782246 2016] [fastcgi:error] [pid 22303] (2)No such file or directory: [client ClientIP:49709] FastCGI: failed to connect to server "/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-mywebiste.fr": connect() failed
    [Sun Nov 13 16:18:03.782316 2016] [fastcgi:error] [pid 22303] [client ClientIP:49709] FastCGI: incomplete headers (0 bytes) received from server "/var/www/clients/client1/web1/cgi-bin/php5-fcgi-*-80-mywebiste.fr"

    What is strange is that there is no mention of php7 in the server configuration, php5 is not installed but all the configuration seems to refer to it...

    PHP Settings web config :

    And the FastCGI conf :

    Of course, this files does not exist...
    I tried to look if php-fpm was stoped, but apparently no...
    # ps aux | grep php-fpm
    root 25331 0.0 0.0 16364 960 pts/0 S+ 16:46 0:00 grep --color=auto php-fpm
    root 31823 0.0 0.1 480476 43052 ? Ss 15:59 0:00 php-fpm: master process (/etc/php/7.0/fpm/php-fp .conf)
    www-data 31825 0.0 0.0 480476 10128 ? S 15:59 0:00 php-fpm: pool www
    www-data 31826 0.0 0.0 480476 10128 ? S 15:59 0:00 php-fpm: pool www

    Does someone got already trouble with an Unbuntu 16.04 fresh install ?
    I have tried three times already (one with automated script), I get always the same issue...

    Thanks in advance

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    That's strange indeed, seems as if the installer was not able to detect your system as ubuntu 16.04 or you updated it from an older Ubuntu release to 16.04. Please change the paths to match the one of your system. I've added a screenshot from my ubuntu 16.04.

    No, I use it here for development currently and it works without issues.

    Attached Files:

    SebUndefiend likes this.
  3. SebUndefiend

    SebUndefiend New Member

    Hi till,
    Thank you very much for your anwser.
    I have changed all the settings as you show in the screenshot. I do not get error in the log anymore and the 500 error disapears. But I get a Blank page for a phpinfo() (php-fpm and modPHP)...
    Could you maybe send me a screenshot of the fast-cgi tab of your server config, I still have php5 reference there... Like FastCGI php.ini Path : /etc/php5/cgi/

    I have installed an hosted server from OVH with Ubuntu 16.04 with the distribution kernel (not the ovh kernel).

    Thanks in advance
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Here it is :)

    Attached Files:

  5. SebUndefiend

    SebUndefiend New Member

    Hi Till,
    Everything works now ! Thank you very much.
    The problem is probably from the OVH ubuntu image... If you need any details from me for adapting the ISPconfig installer, feel free to ask !

    Thanks again !

Share This Page