[SOLVED] Possible attack detected. This action has been logged.

Discussion in 'Installation/Configuration' started by AxelssonDesign, Mar 16, 2018.

  1. zyzzza

    zyzzza Member

    ver 3.2.1 just showed me this message . Any way i can overcome this ?
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Go through this thread and try some of the suggestions/previous solutions and suggestions. If still stuck, post what you have done and the exact log messages you see.
    Last edited: Apr 24, 2021
  3. ajajaj2

    ajajaj2 New Member

    Hi. I have seen this and had this issue in the past. I have solved it.

    It turns out that if your browser runs a lot of addons/extensions that modify the page you are visiting, it will trigger.

    Try disabling all your extensions, ie: lastpass, 1password, rakuten, ublock etc - one or more of them is causing you to get blocked
  4. onastvar

    onastvar Member

    I see "Possible attack detected. This action has been logged." in Safari browser, not in Firefox. I cleared cookies & cache, still an issue in Safari, anyone knows why?
  5. onastvar

    onastvar Member

    [Solved] I had to enable DEVELOP menu in Safari. After i went to DEVELOP > EMPTY CACHES, that fixed it. Message no longer exist.
  6. RalphGL

    RalphGL New Member

    Does it make sense to integrate a feature which produces more false positives than correct warnings?
    In my actual firefox and my chrome, login is only possible in a private session since update to 3.2.6 yesterday.
    If the settings as described in the discussion above are irrelevant for security and can be changed to whatever you want - what does this mean for the relevance of ISP-config security settings?
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    The wrong question, the right one would be: "Does it make sense to integrate a feature which produces more false positives than correct warnings on a correctly installed system?". The answer would be no, and this feature would not exist if it would make false positives warnings on a correctly installed system. And the good thing is, it makes no false warnings at all when your system is set up in the right way. I have this feature active on all systems and never had false-positive warnings.

    Ok, so you know now, that there is something wrong with your setup and neither with ISPConfig nor the IDS system. Things like that happen e.g. when you install other software on the exact same subdomain that you use for ISPConfig and this software tries to inject cookies into ISPConfig. Such a security violation will of course be blocked and is not a false positive. That using private mode works shows exactly that the issue is your browser that tries to inject third party cookies into ISPconfig. As mentioned above, empty browser cache to stop your browser sending invalid data to ISPConfig and then find out which other software you are running on the exact same (sub) domain that injects these cookies and remove that software or change the (sub) domain of that software to one that does not collide with the ISPConfig UI.

    These settings are relevant for security of course. I just reread the thread and found no place where an ISPConfig code dev said that they are not relevant for security. So please don't post such nonsense.
  8. RalphGL

    RalphGL New Member

    Hi Till,
    thank you for your reply. I am sorry if my questions and concern upset you.
    The ISPConfig webfrontend is accessible on my subdomain via port 8080. This is as far as I can remember the defaults during the installation. Other services run on port 443, 80 etc. under this subdomain. I am not aware that it is not allowed to run other services on other ports of the subdomain of ISPConfig. Have I overlooked this in the installation instructions or the documentation?
    Maybe we should discuss this in a new thread?

    Meanwhile i have deactivated all plugins in firefox - and the ispconfig login page is loaded correctly. Soi I activated each addon step by step and still after activating all addons the login does work without any warning.
    In Chrome it doesn't help to remove or deactivate all extensions. With all extensions deactivated the problem remains. The problem was solved after removing all cookies (set by other content of the subdomain) of the subdomain which is used for my ispconfig-installation.
    Last edited: Sep 10, 2021
  9. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so one of your plugins must have sent data or injected cookies and disabling them has cleared a cache in the plugin.

Share This Page