[SOLVED] Problem instalation ISPCONFIG

Discussion in 'Installation/Configuration' started by galfab974, Aug 12, 2015.

  1. galfab974

    galfab974 New Member


    I have got a problem. When i launch install.php i have got a problem :
    >> Initial configuration

    PHP Fatal error: Cannot redeclare error() in /tmp/ispconfig3_install/install/lib/install.lib.php on line 330

    Can you help me please ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    which php version do you use? Please post the output of:

    php -v
  3. galfab974

    galfab974 New Member

    the version is this ISPConfig-

    and php -v :
    PHP 5.4.41-0+deb7u1 (cli) (built: May 22 2015 12:49:18)
    Copyright (c) 1997-2014 The PHP Group
    Zend Engine v2.4.0, Copyright (c) 1998-2014 Zend Technologies
    with XCache v2.0.0, Copyright (c) 2005-2012, by mOo
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Thats starnge, such a conflict might occur with php 7 beta but not php 5.4, are you sure that you have not php 7 beta installed somewhere on this server?
  5. galfab974

    galfab974 New Member

    Normaly no. I do not install php7

    how can i check this?
    aptitude purge php7 or something like that?

    If i comment the function error on the file /tmp/ispconfig3_install/install/lib/install.lib.php on line 330, the installation continu but in can not access to the webmin ispconfig.
    Apache config files are no present and there are nothing in /var/www
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    No, php 7 is a beta, you must have compiled it from source.

    ispconfig is not installed then. There must be something wrong with your php installation. Did you follow exactly the perfect server tutorial and did you start from a empty minimal server?
  7. galfab974

    galfab974 New Member

    I follow the tutorial except for the mail.
    I install Kolab before.
  8. galfab974

    galfab974 New Member

    So i will reinstall a new machine.
    And i configure ispconfig before kolab.
  9. neffs

    neffs New Member

    Just for reference: I had the same problem which could be solved by removing kolabformat.

Share This Page