[SOLVED] pure-ftp + SSL => key values mismatch - any help?

Discussion in 'Installation/Configuration' started by Ovidiu, Nov 14, 2015.

  1. Ovidiu

    Ovidiu Active Member

    Running Debian Jessie + ISPCFG3 + perfect tutorial.
    Followed this tutorial adding SSL/HTTPS via startssl: https://www.howtoforge.com/securing...-free-class1-ssl-certificate-from-startssl-p2 with ONE EXCEPTION: I didn't create my CSR I let startssl create it for me so all I got for downlaod from startssl are the KEY and the CERTIFICATE.

    ISPCFG3 picked up my certificate immediately, postfix/dovecot seem to have no problem but pure-ftp doesn't want to start and give this in the syslog:
    pure-ftpd: (?@?) [ERROR] SSL/TLS [/etc/ssl/private/pure-ftpd.pem](240): error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
    Any hints how to fix?
  2. Ovidiu

    Ovidiu Active Member

    Solved by removing (backing up) the .csr file and following the again, step by step. Not sure what part fixed the issue though.

Share This Page