SOLVED roundcube works for default domain only 16.04

Discussion in 'General' started by firepages, Nov 9, 2018.

  1. firepages

    firepages New Member

    Hi, fresh ISPconfig latest release on ubuntu 16.04
    /webmail and /roundcube work fine for default domain (for any account on any of the hosted domains) and direct via the IP address however all other domains error when accessing /webmail or /roundcube, errors include open_basedir issues which I have added to a test domain, when they go away I get a database driver error 'Unsupported database driver: in /usr/share/roundcube/program/lib/Roundcube/rcube.php on line 1296'

    Since webmail works when accessed through the default site or IP address I assume that the basic configuration is fine, am I missing something glaringly obvious ?
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I tell my users to go to maindomain/webmail for Roundcube.
    If you mean customerdomain.tld/webmail does not work, that is because customerdomain.tld is a website you have made in ISPConfig, and that website does not have Rouncube (unless you install it there) nor the /webmail directory.
    I think there is a setting in ISPConfig that makes webmail a working subdir alias in all websites. It does work on my site, all customerdomain/webmail go to Roundcube.
    No, it is in Rouncube config. Did you forget to do this
    Alias /webmail /var/lib/roundcube
    when following the Perfect Server Guide?
  3. firepages

    firepages New Member

    Hi, thanks for the reply, I did create the alias in local.conf though it already exists in /conf.d as part of roundcube.conf and /roundcube and /webmail both work on the default domain and the IP address.

    I was sure...(though memory is low and somewhat faulty these days) that the in my previous install of ISPconfig the /webmail worked for all tld's in ISPConfig, I could simply be remembering it wrong, if not, any ideas on how to get it to work globally would be appreciated, or at least where to start looking.
  4. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    The /webmail alias does work for all domains in my setup. My understanding is the alias /webmail does it. If that is properly configured, I do not know what could break it.
  5. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    well if /webmail works on the default site/ip then it should work on all domains.
    I guess the first thing to check would be php itself.

    what version of php is it? where is it installed? is php enabled on the other domains? if so, using what php hander, and what php version?
    put a phpinfo.php onto the default site and on one of the domains that's not working and see what differences you can find in the output.
  6. firepages

    firepages New Member

    OK Solved , changing apache handler to fast-cgi fixes it, I had a couple of sites with no PHP enabled at all and a couple with mod-php.
    Again I am sure this used to work out of the box without enabling php in the newly added domains but happy with the result.

    Thanks for the help which pointed me in the right direction.

Share This Page