[SOLVED] Setting up firewall as default prevents ssh connection !

Discussion in 'Installation/Configuration' started by Keoz, Nov 28, 2022.

  1. Keoz

    Keoz Member

    Hosting provider : OVH
    Machine : remote VPS
    OS distro : Ubuntu 22.04 LTS
    SSH user : superuser with sudo rights
    SSH terminal : MacBook Air


    Please help to solve this issue.
    Ssh connection fails as soon as firewall is defaultly setup following this ISPConfig auto-install instructions :

    Screenshot of firewall default setup
    How may I get rid of such this issue ?

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Works fine here, no issues with the Firewall. So probably something specific to OVH and their setup or do you use SSH on a different port? The default SSH port is in the list, so it does not get closed.
  3. Keoz

    Keoz Member

    Effectively, as OVH is recommending it for security reasons, I did change default port 22 for SSH to another port number. Should I add this new port number to the TCP port list in ISPConfig-dashboard/system/firewall ?
  4. Keoz

    Keoz Member

    Adding new port to TCP port list solved the issue, thanks !
    However, I don't remember to have ever faced this issue with previous Ubuntu 20.04 version... !
  5. till

    till Super Moderator Staff Member ISPConfig Developer

    If you close a port in a firewall that you use, then this must stop connections. No matter which Ubuntu version you use.

Share This Page