[SOLVED]Unable to send or Receive email on new install

Discussion in 'General' started by Chris H, Aug 15, 2018.

  1. Chris H

    Chris H New Member

    I am at my wits end I have gone through at least 5 install attempts of ISPConfig 3 and I cant seem to get mail to work.
    I am using Ubuntu 14.04 64bit. I had started with 18.04 but decided to try from an earlier version to see if that would work any better. The only difference between this and other installs I have done is this is on a VPS and I wonder if that is the issue. The install went fine no warnings or errors. DNS records have been up for weeks, DNS zone files in ISPCONFIG are created.

    The following is from the mail log on the new server when I tried to send mail to another server I run greatmoon.net. I never saw this connection attempt on the server greatmoon.net

    Aug 14 20:26:52 localhost postfix/smtp[4800]: connect to mail.greatmoon.net[]:25: Connection timed out
    Aug 14 20:26:52 localhost postfix/smtp[4800]: 9142F7EEBF: to=<[email protected]>, relay=none, delay=31, delays=0.02/0.05/30/0, dsn=4.4.1, status=deferred (connect to mail.greatmoon.net[]:25: Connection timed out)
    I also tried sending email to my gmail address from the asslr.org domain in roundcube and got the error that the network is not reachable but I can ping it from the server just fine. Here is what is showing in the mailqueue

    -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient-------
    9142F7EEBF 946 Wed Aug 15 00:26:21 [email protected]
    (connect to mail.greatmoon.net[]:25: Connection timed out)
    [email protected][
    1F3B37EEB8 945 Tue Aug 14 23:57:11 [email protected]
    (connect to alt2.gmail-smtp-in.l.google.com[2607:f8b0:4002:c00::1b]:25: Network is unreachable)
    [email protected]
    I can send mail locally fine, sending from [email protected] to [email protected] works
    Any assistance is greatly appreciated
  2. florian030

    florian030 ISPConfig Developer ISPConfig Developer

    Maybe your port 25 is blocked for outgoing connections? Try
    telnet mail.greatmoon.net 25
    telnet -6 alt2.gmail-smtp-in.l.google.com 25
  3. Chris H

    Chris H New Member

    the telnet connection to mail.greatmoon.net 25 from asslr.org never connects and eventually just times out
    the telnet connection to google gives an error Unable to connect to remote host: Network is unreachable
    However I can ping that host just fine.
  4. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Contact your vps provider to see if they block port 25 and will allow it for you, and look into disabling ipv6 or getting it setup to work correctly if it's supposed to.
  5. Chris H

    Chris H New Member

    Yeah it seems like they do block port 25, I opened a ticket with them and trying to figure out if it is just outgoing blocked if so I can use a relay to my other server. If it is in and out that is blocked I guess I am pretty much screwed in using email?

    Would have been nice to know before signing an contract with these guys.
  6. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    Pretty much. If you can setup a relay in/out to another mail service on a different port or over a vpn/tunnel you could still run mail service, assuming ports aren't blocked for imap/pop. There are numerous commercial services which support that.
  7. Chris H

    Chris H New Member

    Well fortunately they went ahead and unblocked port 25 for me and mail seems to be working. Just want to thank everyone who popped in and provided assistance you guys are fantastic as always!
    ahrasis likes this.

Share This Page