SOLVED:Wget on jailkit with error on Centos 7

Discussion in 'Installation/Configuration' started by toyinal, Nov 19, 2019.

  1. toyinal

    toyinal Member

    When I ran wget on centos 7 jailkit on ISPCONFIG 3.1 There were errors
    Name or service unknown and 2nd error- Unable to resolve domain

    any help will be appreciated
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    It's not clear to me what you did, did you try to download jailkit sources or did you try to do a download while you are in a jailkit jail?
  3. toyinal

    toyinal Member

  4. till

    till Super Moderator Staff Member ISPConfig Developer

  5. toyinal

    toyinal Member

    I have look at strace of the wget command I only see 1 error pls advice how to correct the error. Thanks

  6. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    Did you refer to the post @till linked to? In that post there were numerous things checked in the original post, and the resolution in the last reply. Their resolver setup in the jail was broken, and they had to copy some additional libraries from the system to the jail, perhaps/likely you have a similar issue.

    If you wish to troubleshoot your specific problem further, please go back to @till's first reply and answer those questions. You have a broken jailkit setup, probably a bad/incomplete jk_init.ini for your OS. The questions of how you installed it are trying to get at what might have happened to cause that.

    I suppose as an alternative to answering the questions you are asked, maybe this will help: try going to the perfect server guide for your OS and run through the "install jailkit" piece again, then reinitialize your jails.
  7. toyinal

    toyinal Member

    The problem was that we have a misconfigured /etc/hosts file with outdated/wrong IP Address. This was corrected and jk_update used to reinitialize the user jail


Share This Page