Solved: why ftp is working?

Discussion in 'Installation/Configuration' started by leonardo.saracini, Sep 30, 2016.

  1. I have installed on VPS a ubuntu 15.10 64bit server and configure all for ISPConfig 3.10
    I create an FTP user (not system) and do not work: refuse connection.
    then I edited on my server /etc/pure-ftpd/db/mysql.conf
    and change the row
    MYSQLCrypt crypt
    MYSQLCrypt any
    I read this conf somewhare.
    save, restart services and all work well: my ftp user right connect to server.
    Why this change work?
    Is changed the way ISPConfig store the psw in the database?
    if so which function is used now to save the psw and where can I found it in the code?
    best regards,
    P.S. I have search but have not found any thread on this configuration
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    No, all ISPConfig 3.0 and 3,1 versions use crypt for the passwords. Maybe you inserted password from another source in encrypted form into the ftp_user table?
  3. No I use ISPConfig web interface and use a Filezilla client on normal ftp protocol and user.
    work only if I set
    MYSQLCrypt any
    sudo apt-cache policy pure-ftpd-mysql
    pure-ftpd-mysql: Installed: 1.0.36-3.2

    Thank for your time,
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    I never heard that:

    MYSQLCrypt crypt

    has to be changed to any. I just verified here that this setting works on Debian 6, 7, 8 and Ubuntu 14.04 and 16.04 and CentOS 6,x and 7.x. I'm sure it works on Ubuntu 15.x as well as we never had an ISPConfig user reporting before that had to change that value.

    Crypt passwords look like this:


    They always start with $ number $ salt $ encrypted password. Take a look at the ftp_user table in the ispconfig database to see how the password looks on your server.
  5. Very sorry it be my mistake.
    the psw on the db have't the look like your post.
    so I set it by ISPConfig web interface, and the psw on the db have the look like your post.
    I have changed the config back to MYSQLCrypt crypt and all work.
    I hypothesize my mistake but I do not guest what is it.
    I had enable log on mysql and see the query pure-ftpd-mysql was doing, so the demon was alive and I had think a fail on psw check.
    If I had post the psw by mysql I had do it because ftp don't were working.
    but now is working by default ISPConfig settings so is all solved.


Share This Page