Some users experiencing ERROR 500 problem

Discussion in 'Installation/Configuration' started by AxelssonDesign, Aug 8, 2017.

  1. Hello,

    Some users are experiencing ERROR 500 on my website while my computers are not showing this error.
    What could be the problem ?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    The reason for the error should be listed in the error.log of this website.
  3. Thanks for replay.

    Here is an php5 error but I'm using php7
    2017/08/08 **:**:** [error] 2273#0: *48468 FastCGI sent in stderr: "PHP message: PHP Warning:  session_start() expects parameter 1 to be array, string given in /var/www/clients/client5/web30/web/wp-includes/class-wp-hook.php on line 298" while reading response header from upstream, client: **.***.***.**, server:, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/lib/php5-fpm/web30.sock:", host: ""
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    The error message does not indicate if the site uses PHP 5 or PHP 7, the socket path is the same for all PHP versions. If you want to know the php version, add a phpinfo() file in the website. And regarding this error, you pass a wrong variable type to the session_start() function.
  5. Thanks for replay.

    Here is my phpinfo():
    PHP Version 7.1.2
    System     Linux 3.16.0-4-amd64 #1 SMP Debian 3.16.43-2+deb8u2 (2017-06-26) x86_64
    Build Date     May 7 2017 19:12:09
    Configure Command     './configure' '--prefix=/opt/php-7.1' '--with-pdo-pgsql' '--with-zlib-dir' '--with-freetype-dir' '--enable-mbstring' '--with-libxml-dir=/usr' '--enable-soap' '--enable-calendar' '--with-curl' '--with-mcrypt' '--with-gd' '--with-pgsql' '--disable-rpath' '--enable-inline-optimization' '--with-bz2' '--with-zlib' '--enable-sockets' '--enable-sysvsem' '--enable-sysvshm' '--enable-pcntl' '--enable-mbregex' '--enable-exif' '--enable-bcmath' '--with-mhash' '--enable-zip' '--with-pcre-regex' '--with-pdo-mysql' '--with-mysqli' '--with-mysql-sock=/var/run/mysqld/mysqld.sock' '--with-jpeg-dir=/usr' '--with-png-dir=/usr' '--enable-gd-native-ttf' '--with-openssl' '--with-fpm-user=www-data' '--with-fpm-group=www-data' '--with-libdir=/lib/x86_64-linux-gnu' '--enable-ftp' '--with-imap' '--with-imap-ssl' '--with-kerberos' '--with-gettext' '--with-xmlrpc' '--with-xsl' '--enable-opcache' '--enable-fpm'
    Server API     FPM/FastCGI
    Virtual Directory Support     disabled
    Configuration File (php.ini) Path     /opt/php-7.1/lib
    Loaded Configuration File     /opt/php-7.1/lib/php.ini
    Scan this dir for additional .ini files     (none)
    Additional .ini files parsed     (none)
    PHP API     20160303
    PHP Extension     20160303
    Zend Extension     320160303
    Zend Extension Build     API320160303,NTS
    PHP Extension Build     API20160303,NTS
    Debug Build     no
    Thread Safety     disabled
    Zend Signal Handling     enabled
    Zend Memory Manager     enabled
    Zend Multibyte Support     provided by mbstring
    IPv6 Support     enabled
    DTrace Support     disabled
    Registered PHP Streams    https, ftps, compress.zlib, compress.bzip2, php, file, glob, data, http, ftp, phar, zip
    Registered Stream Socket Transports    tcp, udp, unix, udg, ssl, tls, tlsv1.0, tlsv1.1, tlsv1.2
    Registered Stream Filters    zlib.*, bzip2.*, convert.iconv.*, mcrypt.*, mdecrypt.*, string.rot13, string.toupper, string.tolower, string.strip_tags, convert.*, consumed, dechunk
    Zend logo This program makes use of the Zend Scripting Language Engine:
    Zend Engine v3.1.0, Copyright (c) 1998-2017 Zend Technologies
        with Zend OPcache v7.1.2, Copyright (c) 1999-2017, by Zend Technologies
    Is the problem in my ispConfig setup or the php code ?
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    That's a problem with the PHP code. As you can see, PHP 7.1 is used. There is a lot of software that is not compatible with PHP 7.1, so I would recommend switching the site to PHP 7.0 or PHP 5.6 if you have multiple PHP versions installed to see if it works then.

Share This Page