SQL dump error

Discussion in 'Installation/Configuration' started by luisdaniel, Feb 24, 2015.

  1. luisdaniel

    luisdaniel New Member

    I had some issues about installation and uninstalation of ispconfig 3 stable, and I'm using centos 7.

    First of all, I think I found some kind of bug. I tried uninstall, after an unsuccessful installation, using uninstall.php and uninstall-fedora.php, but both report an error, can't find the file /usr/local/ispconfig/server/lib/config.inc.php, because the installation didn't create it and doesn't exist, but there are other configurations like database and apache (httpd) exist and they are messing up the start up of apache.

    The point is, I have some configuration but not everything, it can be called corrupted configuration. I can't uninstall because is missing files. So is missing something in middle, something I'll call purge. So maybe is good to have a purge.php, it tries to clean the default configuration and why not ask to the user for some configuration filled up.

    For now, I'm trying to clean much as possible and do another installation hopping have a successful work. If not, I'll back to this post to have more help with community.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    Do these steps to cleanup your system:

    1) Delete the folder /usr/local/ispconfig
    2) Remove the dbispconfig database
    3) remove the ispconfig mysql user
  3. luisdaniel

    luisdaniel New Member

    Ok, now another error, mariadb can't start because it says can't create /var/lib/mysql, I don't know what I have done, specially because I worked late and tired so I may have done something wrong. I'll try to fixe it.

    About your tips, the first one no need because that directory was never created. The second tip, is the problem, I saw the directory /var/lib/mysql and the files with the database name, but now the directory doesn't exist anymore and that happens after I shutdown the mariadb service, so it's a virtual directory (alias/link) created by mariadb? (NO, it isn't)

    I'm getting a little frustrated and annoying but I won't give up. The server need to be up and full functional.
    I'm keep googling the problem.

    [update] I lost the directory, I don't know how, the only thing I need to do is rebuild the database, and what I did is create the directory (mkdir /var/lib/mysql), set the owner and group to mysql (chown mysql:mysql /var/lib/mysql) and start the service, the service created a blank database. (text inside this means command I did)
    Last edited: Feb 24, 2015

Share This Page