Startup error with ISPConfig. Syntax error on line 206 of ...

Discussion in 'Installation/Configuration' started by Mefistofeles, Jun 20, 2007.

  1. Mefistofeles

    Mefistofeles New Member


    Syntax error on line 206 of /root/ispconfig/httpd/conf/httpd.conf:
    Cannot load /usr/lib/apache/modules/ into server: /usr/lib/apache2/modules/ undefined symbol: apr_pool_cleanup_null
    /root/ispconfig/httpd/bin/apachectl startssl: httpd could not be started

    Thats my problem.. Any ideas?
  2. mlz

    mlz New Member

    Did you follow a perfect install? Sounds like mod_rewrite isn't installed.
  3. Mefistofeles

    Mefistofeles New Member

    I think i followed an Ubuntu perfect install. Cant remember for sure what versions. A long time has passed since the install was made. :) The thing is that about 2-3 month ago there was this web page that "landed" in our server and needed mod-rewrite. So I installed/configured it. And I believe that it worked at the beginning. Since then i haven't had a reason to use ISPConfig so I don't know since when the problem has existed.

    Anyway.. I should try reinstall mod-rewrite, to see if it fixes it.. Any good walktroughs someone could recommend? So I would get everything 100% right.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    You loaded a mod_rewrite for apache 2.0 in the apache server for ISPConfig which is a apache 1.3 in the file /root/ispconfig/httpd/conf/httpd.conf.

    Please uncomment the line 206 where you load the module in /root/ispconfig/httpd/conf/httpd.conf.

    The ISPConfig webserver is not used to serve your webpages, so never load any additional modules in /root/ispconfig/httpd/conf/httpd.conf.
  5. Mefistofeles

    Mefistofeles New Member

    hm.. Oh.. Thats right.. What a stupid mistake. No wonder nothing I did to fix it worked :D Thanks :eek:

Share This Page