Static IP address doesn't work - DHCP does

Discussion in 'Installation/Configuration' started by edopizza, May 12, 2006.

  1. edopizza

    edopizza New Member

    I am trying to install a Debian 3.1 server with the help of this tutorial

    When I want to change from DHCP to static, it become impossible to connect to the internet, even after a complete reboot. I can still ping the router and the other computers in my LAN, and I get pinged by the other computers.
    The IP I choose is in the correct router's range for the static IP.
    ifconfig will show the choosed static ip but the router list wont list it.

    I had exactly the same problem with my father's computer which run win98; I thought it was due to the fact it is an old box and I then left his computer running on DHCP.

    Has anybody found the solution for that problem?
  2. falko

    falko Super Moderator Howtoforge Staff

    Make sure you use the correct gateway IP address (your router's local IP address). Also specifiy valid nameservers in /etc/resolv.conf (you can use those from the tutorial). And finally make sure that you don't give your system an IP address that is already used by another computer in your LAN.
  3. edopizza

    edopizza New Member

    Still in trouble...

    Hello Falko, thanks for you help.
    I checked and rechecked the settings and everything should be correct but the system still don't want to connect to the wan. I am going to reinstall all from the beginning without plugging the lan cable, so the installer is going to ask me for the network settings.

    About /etc/resolv.conf, I tryed three settings:
    first with the two DNS my IPS gave, second with the router IP and third with both of them. Nothing seems to improve.

    What is the correct setting for the DNS?
  4. falko

    falko Super Moderator Howtoforge Staff

    What's in /etc/network/interfaces?

    You can use the nameservers mentioned in the tutorial. They work fine.
  5. edopizza

    edopizza New Member


    # The loopback interface
    auto lo
    iface lo inet loopback

    # The first network card - this entry was created during the Debian installation
    # (network, broadcast and gateway are optional)
    auto eth0
    iface eth0 inet static
  6. falko

    falko Super Moderator Howtoforge Staff

    Looks ok so far. Is your router's internal IP address?
  7. edopizza

    edopizza New Member

    By the way...

    By the (gate)way I solved the problem by reinstalling all with the option "linux netcfg/disable_dhcp=true".
    In the /ect/network/interfaces there are now two lines more:


    Thanks for your inspiration!

Share This Page