stats for website

Discussion in 'Installation/Configuration' started by rajbps, Apr 20, 2016.

  1. rajbps

    rajbps Member

    Hi Team,

    I have installed the latest version of ispconfig on centos 7.
    Created a website and now trying to get the stats from it.
    On ispconfig, went on the site and created a password under statistics.

    Now went to open it via:
    That brings up a prompt asking a username and password :
    A user name and password are being requested by The site says: "Members Only"

    If i put in username as : admin
    and password as generated, it does not give me access.

    Site is running wordpress.

    can anyone advise.


  2. rajbps

    rajbps Member

    Hi team,

    Anyone has any ideas on this one please?

  3. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    To eliminate Wordpress, rename the .htaccess file in the website root and see what happens.

    What do you see at this point?
  4. Jesse Norell

    Jesse Norell Well-Known Member Staff Member Howtoforge Staff

    As a point of curiosity, I tried this with a minimal/default wordpress install (ie. no plugins, and permalinks are default/off); prior to setting up a password for stats, going to /stats/ did ask for a password, and then gave me an Ispconfig generated error (probably 403, but it's gone now...); after I set a password (waited a minute) and reloaded, I entered the correct password and it now shows me webalizer stats.
  5. rajbps

    rajbps Member

    ok i get the following after putting the user admin and its password
    it keeps asking it.
    So i checked the permission of the stats folder inside that domain and it was owned by root.

    So i changed it to that user and I get:
    The following error occurred:
    You are not permitted to access the requested URL.

    Please contact the webmaster with any queries.

    I have rebooted the server but still the same :-(
  6. rajbps

    rajbps Member

    hi Team,

    Anyone any ideas on thi soneplease?

  7. chaosad

    chaosad New Member

    have you any files at stats?
    my problem on centos and awstats is, I only have a index.php @stats
  8. rajbps

    rajbps Member

    Thats all I have also
  9. rajbps

    rajbps Member

    Hi Team,

    Anyone any ideas please?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    Check that awstats is instaleld and that the paths to the awstats scripts that can be configured under system > server config are correct.
  11. rajbps

    rajbps Member

    Here are the settings on the web interface :
    awstats conf folder /etc/awstats
    awstats data folder /var/lib/awstats script /usr/lib/cgi-bin/ script /usr/share/awstats/tools/
    I have cent os 7 installed and I cant find "webalizer" for centos 7.
    I do have awstats installed .
    The way i have tried is go on the ispconfig page and then under site selected the site and then statistics and genereated the password.
    Then went on the website url as and it asks for a login so I used admin and the password.

    This brings an error :

    Jump to previous stats:

    ERROR 404 - Not Found!

    The following error occurred:
    The requested URL was not found on this server.

    Please check the URL or contact the webmaster.

    I am now lost.

    Any help is welcome.

  12. rajbps

    rajbps Member

    Hi Team,

    Anyone with any ideas on this one.
    I have selected webanalyser and put the password and left it for a few days but still nothing.
    Any pointer would be great

  13. rajbps

    rajbps Member

    sorry i meant to say awststs not webanalyser :)
  14. till

    till Super Moderator Staff Member ISPConfig Developer

    You posted the paths above but you did not say if you checked if the settings match your awstats installation. e.g. do a :

    ls -la /usr/share/awstats/tools/

    to see if the is really in that location.
  15. rajbps

    rajbps Member

    Thats the return for that :

    ls -la /usr/share/awstats/tools/
    -rwxr-xr-x. 1 root root 19787 Mar 1 20:50 /usr/share/awstats/tools/
  16. rajbps

    rajbps Member

    Hi Team,

    Had a look at the logs and this is what I get as error :

    Cannot serve directory /var/www/customerdomain/web/stats/: No matching DirectoryIndex (index.html,index.php) found, and server-generated directory index forbidden by Options directive

    When trying to access the stats

    Anyone any ideas please?

  17. rajbps

    rajbps Member

    Hi Team,
    The path under
    System => server config ==> web and then AWStats Settings
    The path for " script" was different so I change it to "/usr/share/awstats/wwwroot/cgi-bin/"
    Rebooted the server and left it for over 48hrs and still no stats :-(
    Can anyone assist please
  18. rajbps

    rajbps Member

    Hi Team,
    I waited a few days but still nothingget populated.

    Could anyone advise


Share This Page