Strange behaviour when creating websites which are not working until restarting apache

Discussion in 'Installation/Configuration' started by AngeloAvv, Mar 28, 2018.

  1. AngeloAvv

    AngeloAvv New Member

    Hi, I'm experiencing a very strange behaviour on my new setup of ISPConfig 3.1.11. It's running inside a Docker container created by jerob (I'm using a custom jerob/docker-ispconfig image edited to support pure-ftpd on OpenVZ).
    As far as I can tell, I can't create a working website, since every one I create gets marked as an "error". ISP says that the creation has gone well, but as soon as I look into /etc/apache2/sites-available, I can only see vhosts with an .err estension.

    At the beginning I was very sure it was an SSL related problem, but then I figured out that the website works if I stop apache from running, copying the .err vhost content into the .vhost real file and restarting apache2. This keeps working until I go to change my website configuration, in that cose something under the hood occurs, and ISPConfig marks my vhost as an .err file again.

    Any suggestions?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    A file gets marked as .eerr when ispconfig is not able to restart apache. So maybe there is an issue with the init system inside your docker container that prevents a successful restart. You can try to use the ISPConfig debug mode to find out what happens behind the scenes.
  3. AngeloAvv

    AngeloAvv New Member

    Reason for Apache restart failure: /bin/systemctl: line 4: /etc/init.d/apache2.service: No such file or directory

    Apache did not restart after the configuration change for website Reverting the configuration. Saved non-working config as /etc/apache2/sites-available/

    Seems like systemctl isn't able to start apache2.service. If I execute manually
    systemctl restart apache2.service, the command line prints out
    /bin/systemctl: line 4: /etc/init.d/apache2.service: No such file or directory

    but if I execute manually systemctl restart apache2, it works like a charm
    [....] Restarting Apache httpd web server: apache2AH00548: NameVirtualHost has no effect and will be removed in the next release /etc/apache2/sites-enabled/000-ispconfig.conf:73
    AH00558: apache2: Could not reliably determine the server's fully qualified domain name, using Set the 'ServerName' directive globally to suppress this message
    . ok
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Ok, so it's an issue in your docker image. Using the command "systemctl restart apache2.service" on Ubuntu and Debian servers and vservers works flawlessly.

Share This Page