Strange Permission Denied error

Discussion in 'Server Operation' started by garg, Apr 1, 2009.

  1. garg

    garg New Member

    I have a debian etch server that has a dhcp server and webmin installed. Webmin and dhcp works great. Now I wanted to install a web app so I needed to install apache.

    I installed it and with out changing any thing it started saying and it started giving 403 errors and

    You don't have permission to access / on this server.

    Error log said:

    [Wed Apr 01 13:33:57 2009] [error] [client my_ip] (13)Permission denied: access to / denied

    I decided to remove everything and start over so I did

    apt-get --purge remove apache*

    This got rid of everything apache and then I did:

    apt-get install apache2 apache2-doc apache2-mpm-prefork apache2-utils libexpat1 ssl-cert

    apt-get install libapache2-mod-php5 php5 php5-common php5-curl php5-dev php5-gd php5-idn php-pear php5-imagick php5-imap php5-json php5-mcrypt php5-memcache php5-mhash php5-ming php5-mysql php5-ps php5-pspell php5-recode php5-snmp php5-sqlite php5-tidy php5-xmlrpc php5-xsl

    (basically all the apache steps shown here )

    Then I browsed to the IP and it gave me the exact something. I know it's not cached, and I have rebooted and force-reloaded.

    I have tried to make /var/www/ 777 and I've changed the owner/group to www-data and then later root (default). I have made an index.html file inside and made that 777.

    Anything I do keeps giving me the same 403 error.

    Any ideas?
  2. garg

    garg New Member

    I just uninstalled webmin as well. Then uninstalled all of apache and php. I did rm -rf to /etc/apache2.

    And then reinstalled with apt-get and then I go to <server addr> I get 403 error again.

    What seems to have happened to this server? haha
  3. garg

    garg New Member

    Some thing was corrupt. I reinstalled the server from scratch and now it works :)

Share This Page