Strange Virtual Host Issue

Discussion in 'General' started by mgrimes, Aug 12, 2017.

  1. mgrimes

    mgrimes New Member

    EDIT: So it appears to be something with the domain that I am using and ISPConfig - I am convinced! I just took a domain that I had forwarding at the DNS level and added it to my list of virtual hosts - no problem at all. The domain that I am using begins with the word 'exit' and as crazy as this may sound, I think that is causing the problem. Any other domain is parsing the files in the correct directory, however the one that I am trying to work on, exitrealtyjackson, is not. ARGH!*@&@^#^ Aside from adding a config file outside of the ISPConfig system, I can't figure this out.

    I have an installation of ISPConfig 3.1.6 and it has been running fine for over a year. Today, I went to add a new client and a virtual host and no matter what I do, this domain is not displaying the client folder. Instead, it is showing my server /var/www/ default index.html. As a test to prove I was not crazy, I tried adding a subdomain "test.theddomain" and viola - I get the expected result - "Welcome to your new site" page, not my default /var/www/index.html.

    I have checked the vhost config file and everything is the way it should be. No errors in my log files and I even went as far as to disable my 000-default config, but nothing is fixing this problem. Any ideas? Any input would be greatly appreciated as I am literally about to bang my head against the wall.
    Attached is the config file for the vhost, output by ISPConfig like any other domain (and I host quite a few with no problem)...

    Thank you in advance!


    Attached Files:

    Last edited: Aug 13, 2017
  2. Jesse Norell

    Jesse Norell ISPConfig Developer Staff Member ISPConfig Developer

    don't know what your os/server is, but I just tested that domain on debian jessie with apache and it worked fine (including php in fastcgi and fpm modes).

    Your vhost uses '*' as the ip address, maybe your default vhost has the actual ip address set? That would give you the same results. Supply 'apachectl -S' info if you're running apache.

Share This Page