Subdomain not creating correctly.

Discussion in 'Installation/Configuration' started by valtech, Jan 23, 2016.

  1. valtech

    valtech New Member

    I know this has been covered before, I tried what has been suggested, but it does not seem to work.

    What I want, is for to point to it's own folder as a separate website. is a FQDN and working perfectly.
    So I created as a separate website in ISPConfig, with A Records for, ns1, ns2, www. I also created FTP account so I can upload the new sites' files.
    After this I was expecting to have a separate site and to be able to FTP the files up with the username registered for it
    Attempting to access the site shows 'server error' FTP does not work either - gives authentication failure.
    Checking manually via CLI;
    there are entries for a the (and other websites hosted on the server). But nothing for I was expecting to see an entry for that too if it is a separate website, and a full website structure under var/www/web/. Isn't that right?

    The site and its' DNS are listed correctly in ISPConfig though.

    Any help much appreciated!
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. valtech

    valtech New Member

    Thank you for reply Tim

    I'm running ISPConfig on Ubuntu server 14.04.03LTS. Php v 5.5.9 running PHP-FPM for both main sites.
    Only 1 server in the system.

    Followed that last chapter and:
    PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 49152 bytes) in /usr/local/ispconfig/server/server.php on line 148
    PHP Fatal error: Allowed memory size of 262144 bytes exhausted (tried to allocate 5760 bytes) in /usr/local/ispconfig/server/lib/ on line 98

    The server has 8Gb of RAM and runs 2 Presta Shop 1.6 sites (not very busy either!), so hopefully should not happen!

    I've checked the System State> Job Queue... The queue is massive! Dating back to 11/01/2016. Not seen anything in the queue before.

    Thanks for your help !
  4. valtech

    valtech New Member

    Thank you again - I'm on the right path, I think...
    Initial inststall check scrip would not run - due to lack of memory!
    More digging..
    Checked memory_limit in all php.ini I could find...
    memory_limit was set to 4000M in all php.ini! Took it down to 756M for all processes.

    Now check scrip runs, job queue emptied itself.
    Last on the check script run ....
    Writing BIND domain file failed: /etc/bind/ zone NS '' has no address records (A or AAAA) zone NS '' has no address records (A or AAAA) zone /IN: not loaded due to errors.

    Now I do have a separate directory for the new site under var/www/and I'm able to create FTP account and access it via Filezilla!
    One left to sort.. DNS issue with BIND.

    MASSIVE thank you Tim for helping with this!
  5. valtech

    valtech New Member

    And everything is finally working after a little wait (few hours)! Even DNS!
    Thanks again for all your help!

    Can be marked as SOLVED!

Share This Page