sudo to enable root on Ubuntu 7.10 server

Discussion in 'Installation/Configuration' started by klf, Dec 20, 2007.

  1. klf

    klf New Member

    Just a short question on basics, but why can I not enable the sudo command after building Ubuntu Server 7.10? The system will not allow me to use sudo to enable root.

    Like your input and interest in building this server, but I may have to use 6.06.1 server edition, as that allows me to work with the sudo command.
  2. Leszek

    Leszek Member

    What's in /etc/sudoers file ?
  3. shadoza

    shadoza New Member

    Think I Solved Your Problem

    Hi. I am super new to linux, about two weeks. I am installing 7.10 to try out some layer 7 filtering applications. I had clean installed the server using the whole disk a couple of times due to mistakes made installing the layer 7 packet filtering stuff. After about the third or fourth time reinstalling, I kept getting a no sudoer error like you! It was very frustrating. It resulted in three days of lost work, about 30 fresh installs of the OS trying numberous different things. I read your post yesterday and you talked about the other ubuntu server and after about 3 failed attempts at getting sudoer access I started looking into the other ubuntu server you spoke of. While researching the differences between the two systems I came across this in the release notes Link:
    If the mail-server task is selected during installation and "No configuration" is selected in response to the question "General type of mail configuration:", then the initial user will be set up without sudo access.
    To repair this, boot in recovery mode and run:

    addgroup --system admin
    adduser USERNAME admin
    echo '%admin ALL=(ALL) ALL' >>/etc/sudoers


    My problems sounded a lot like yours, I am doing an install while I am writing this, and I already left the mail options the bad way, so I am going to try and fix it like the instructions above say, if I can't figure it out I will just re-install and let you know the results!
  4. shadoza

    shadoza New Member

    Good News! It worked for me. If you have the same problem where no matter what you can't get the sudo to work, and the /etc/sudoers is listed but when you try to access it, it says it doesn't exist, then this is the cause and solution.

    I don't know if the commands worked for me because how I had this current install configured I made the grub partition too big so I was never able to see the results. I just clean installed.
  5. klf

    klf New Member

    sudo and mail server configuration

    Thank you for your help shadoza. This worked, and thanks for the link to the 7.10 help file. There was nothing in the etc/sudoers file, as I built the mail server with no initial configuration, I could not access the sudoers file.

Share This Page