suPHP 0.7.0 compatible with ISPConfig2 ?

Discussion in 'Installation/Configuration' started by Hans, Dec 27, 2008.

  1. Hans

    Hans Moderator ISPConfig Developer

    On 25-12-2008 suPHP 0.7.0 has been released. Within this release, some major items has slightly changed and for this reason, i was wondering if it is compatible with the current ISPConfig version 2.2.29.

    On a Debian test-server with ISPConfig 2.2.29 and suPHP 0.6.3 installed, i did the following to upgrade suPHP to version 0.7.0:

    cd /tmp
    tar xvfz suphp-0.7.0.tar.gz
    cd suphp-0.7.0
    ./configure --prefix=/usr --sysconfdir=/etc --with-apache-user=www-data --with-setid-mode=paranoid --with-apxs=/usr/bin/apxs2
    make install

    The result:
    sites which make use of suPHP did not work anymore and an Internal server error occurred. Within the log file of the web i saw errors like:

    SecurityException in Application.cpp:511: Unknown Interpreter: php
    Premature end of script headers: index.php

    Within the log file /var/log/suphp.log nothing appears.

    Probably, to use suPHP 0.7.0 on an ISPConfig 2 server some items need to be configured. Anyway, after puzzling for some time, i don't get it to work the normal way.

    Maybe this problem is because suPHP_AddHandler and suPHP_RemoveHandler directives can now be used on per vhost level, but i'm not sure.

    Can you ISPConfig developers have a look at this behaviour and find a solution. Until then, i don't recommend to upgrade to suPHP 0.7.0 yet. (Remember that ít is not a security release).

    Thanks in advance!
    Last edited: Dec 27, 2008
  2. dtrotter

    dtrotter New Member

    Can you post your /etc/suphp.conf file for me (us) to examine? I have not tried 0.7.0 yet, but can look through the config to look for inconsistencies...

  3. Hans

    Hans Moderator ISPConfig Developer

    Thanks for your reply.
    Within the attachment, you find the config file. (I renamed it suphp.conf to suphp.txt).

    Attached Files:

    Last edited: Dec 27, 2008
  4. usul

    usul New Member

    I had the same problem with version 0.7.0 is suPHP, which I have just solved.
    The problem lies in the configuration file, you enter "" as shown below.

  5. Hans

    Hans Moderator ISPConfig Developer

    Thanks for your reply!
    I will try your solution on a test server. :)
  6. usul

    usul New Member

    Wait to thank me ... hihi:D:rolleyes:;)
    sorry but there is still a mistake made on my part, this is the correct version is tested for ISPCONFIG.

    ;Path to logfile
    ;User Apache is running as
    ;Path all scripts have to be in
    ;Path to chroot() to before executing script
    ; Security options
    ;Check wheter script is within DOCUMENT_ROOT
    ;Send minor error messages to browser
    ;PATH environment variable
    ;Umask to set, specify in octal notation
    ; Minimum UID
    ; Minimum GID
    ;Handler for php-scripts
    ;Handler for CGI-scripts
  7. Hans

    Hans Moderator ISPConfig Developer

    Ok then i will use that solution! :)
    I'll let you know if it works for me as well.

    In the mean time i've installed suPHP 0.7.0 on a Debian test server with ISPConfig 2.2.29, and i can confirm it works great!

    Thanks again for your solution.
    Last edited: Jan 9, 2009
  8. megabitdragon

    megabitdragon New Member

    How exactly did yo make it work. Any special settings?I tried to install ispconfig svn version and suphp 0.7.0 on an ubuntu 8.04 LTS server. The ubuntu installation was fresh following the perfect ubuntu server 8.04 tutorial:
    To compile suphp I used the tutorial from:

    When I try to access index.php I get 500 error internal server error.

    Any ideas?
  9. Hans

    Hans Moderator ISPConfig Developer

    Make sure you have the following lines at the end of your suphp.conf:

    ;Handler for php-scripts

    ;Handler for CGI-scripts

    Then it should work.
  10. megabitdragon

    megabitdragon New Member

    Thanks for your help.
    I think that small details make all the difference. I had the same lines in my suphp.conf file but without the quotes.
    Now everything works as expected

    Thank you

Share This Page