suPHP & Joomla

Discussion in 'Installation/Configuration' started by SamTzu, Sep 17, 2009.

  1. SamTzu

    SamTzu Active Member

    I created a OpenVZ virtual server for the purpose of creating quickly Joomla test sites.

    I used Ubuntu 8.04 Template in ProxMox.
    After that I followed the Perfect Server Guide for it where it started to actually install packages.

    ISPConfig2 seems to work fine except for one small problem.
    Sites are created with suPHP permissions but new files/components uploaded with Joomla are created with www-data:www-data as owner.

    Any idea where to start to debuging this?

  2. falko

    falko Super Moderator Howtoforge Staff

    Is the Joomla site running with mod_php? Can you post the vhost configuration of the Joomla vhost?
  3. SamTzu

    SamTzu Active Member

    I'm not sure how to check the mod_php use in ISPConfig2.

    Here is the Vhosts....

  4. falko

    falko Super Moderator Howtoforge Staff

    Yes, you're using mod_php which means that files uploaded via PHP will be owned by the Apache user and group (which is www-data on Debian/Ubuntu).
  5. SamTzu

    SamTzu Active Member

    Last edited: Sep 19, 2009
  6. falko

    falko Super Moderator Howtoforge Staff

  7. _X_

    _X_ New Member

    I suggest using new version of suPHP since 6.2 had a rather nasty security problems with symlinks.

    is the latest at the moment.

    btw ... what are advantages of suPHP, except file owner issue. Are there any problems that suPHP can cause?

    How suPHP is updated after this install?

    Can apt-get update it automatically?
  8. SamTzu

    SamTzu Active Member

    Did not work with that version.
    I got it to work with these commands...

    (Other wise browser / server wants to download the php files.)

    vi /etc/sysconfig/apache2

    [...]APACHE_MODULES="actions alias auth_basic authn_file authz_host authz_groupfile authz_default authz_user authn_dbm autoindex cgi dir env expires include log_config mime negotiation setenvif ssl suexec userdir rewrite ruby"[...]

    Thanks for all your help.

    I wonder what is the last suPHP version that works with this?
    Last edited: Sep 22, 2009
  9. falko

    falko Super Moderator Howtoforge Staff

  10. SamTzu

    SamTzu Active Member

    I tried that. It did not work with suPHP 0.7.1.
    For some reason after upgrade the server gives 'Ineternal Server Errors.'
    It complains about a fault in the suPHP installation script.
  11. falko

    falko Super Moderator Howtoforge Staff

    What's the exact error message?
    Are there any errors in Apache's error log?
  12. tprpicscom

    tprpicscom New Member

    CentOS 5.3 ISPconfig 2 suPHP configuration problem

    Hello and thank you for the excellent work on the perfect servers and the tutorials. I am however struggling with the suPHP instructions mentioned in this thread. I have tried both v6.2 and v0.7.1 of suPHP and seem to have the same issue.

    After installing suPHP and removing the LoadModule for php and adding the LoadModule for suPHP as well as adjusting the go_info line and /etc/suphp.conf files my php pages do not want to load - the browser prompts to download them. I have enabled and disabled the PHP mark on the vhost config but the vhost configuration seems to be the same. Specifically:

    AddType application/x-httpd-php .php .php3 .php4 .php5
    php_admin_flag safe_mode Off

    Any help is appreciated.


  13. falko

    falko Super Moderator Howtoforge Staff

  14. tprpicscom

    tprpicscom New Member


    Yes I did. I actually got it working but using those instructions and then making these manual modifications.

    in /etc/suphp.conf (could not get it to work with the php wrapper)


    ;Handler for CGI-scripts

    in /etc/httpd/conf/vhosts/Vhosts_ispconfig.conf

    suPHP_Engine on
    suPHP_UserGroup web6_webmaster web6
    AddHandler x-httpd-php5 .php .php3 .php4 .php5
    suPHP_AddHandler x-httpd-php5

Share This Page