SuSE + sendmail + vacation ==> no auto-reply is sent

Discussion in 'Server Operation' started by paux, Jun 6, 2009.

  1. paux

    paux New Member

    Hey folks,

    I ran into a problem which does puzzle me. My setup is

    SuSE 9.2 (YES it's OLD)

    And right before anyone complains, no I cannot upgrade at this point! :)

    Now the thing is, that I am hosting two domains on that system, both having mail and webspace on the same server using the programs mentioned above. Today I setup vacation and it does work fine for one local user (who has one mail addresse of one of the domains attached to it).
    Then I tried to setup vacation for one local user of that other domain who has a couple of mail addresses attached and it does not work. I can see the mail (from a 3rd party) coming in and being forwarded to vacation but the log entires made look completey different from the ones that works correctly. The mail does arrive but no autoreply is being sent back to the sender.
    I have tried a couple of things, like erasing the *db files, reinitiating the vacation for that user, and so on.
    Now if I setup a mail address from the not-working domain for the local user who does work fine with the other domain it stops working for that user as well. Same result, mail comes in, is being dropped to the local mail file, logfile shows mails is being piped through vacation but no auto-reply is being sent.

    ....any bright ideas?!?! Any help is highly appreciated!!

  2. falko

    falko Super Moderator ISPConfig Developer

    Can you post excerpts of your mail log when vacation is working and when it is not working?
  3. paux

    paux New Member

    Hi Falko,

    thanks for your reply! :)
    Was already thinking about posting the logs, but then found out that the version of vacation I use (as the rest of the entire software my providers provides for me) is really old. So basically it was PEBKEC :(
    I used the '-a' the wrong way, seems it has changed since the version I have to use and I was checking back with the wrong manual - since man pages are disabled on that system!

    So it all works fine now!


Share This Page