Suspended Site Routing to Another Client vs Default Server Page

Discussion in 'General' started by DDArt, Mar 29, 2021.

  1. DDArt

    DDArt Member

    I noticed the following:

    A domain I suspended awhile back (ie. olddomain.tld) if you click on it goes to some random.tld.
    I verified random.tld and the source ip/bind is not "*" but the server ip.
    I disabled random.tld and goes to anotherrandom.tld domain, I checked that and that as well has IP bound.

    I verified and re-enabled a genericservername.tld and has a parked page. I enabled IP bind to "*" all.
    I also enabled another another ispconfig serverhost url when was setup like admin.genericservername.tld with "*". I figured if they rotate between the two they have the same text/generic html static index.html.

    Checked the directory/vhost file
            AllowOverride None
                    Require all denied
    <VirtualHost *:80>
                        DocumentRoot /var/www/clients/client1/web5/web
            ServerName admin.genericservername.tld.vhost
    I just commented out anything ipv6 in my /etc/hosts
    Any feedback is appreciated.
  2. Taleman

    Taleman Well-Known Member HowtoForge Supporter

  3. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    As @Taleman pointed out, this is covered in the read before posting. When the domain is disabled, it will show the first site in alphabetical order. Create a web "" or something like that so users see a page that belongs to you instead of someone elses website.
  4. DDArt

    DDArt Member

    I have tried, and apology for not doing that before posting, I attempted to delete the post and run the troubleshooting script.
    This might be a git request for future update/feature maybe but if I recall the installation howto from back in Debian 7,8,9, etc it stated to generate a generic default host and have a park page there where you can also create a ssl cert, and use the let's encrypt cert to use with your ISPConfig panel. So instead of using clientdomain.tld:8080 and get the cert warnings better point everyone to a generic gateway like https://panel.genericdomain.tld:8080.

    Secondly, it is ideal to have a main/server generic park page with some 2-3 paragraphs stating something to the tune of, if you see this page, your domain, has either been suspended, and you need to contact your host person, that'd be ideal vs getting some random domain next in line because of whatever is in the alphabet order.

    Having panel.genericdomain.tld vhost settings set to capture * all vs associate with IP worked well, the rest of the domains all associated by IP address. When I would suspend a site, or let's say a person pointed their domain to my servers, via ns, but I never created the account, they would at least get this generic page. It's not just about suspension or activation.

    Something has changed since few versions back and I'll go read up on it and see about how to make this happen manually editing files vs using the panel.

    Thank you,
  5. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    I create website 0000aaa.tld on my ISPConfig hosts. It does not have to be in DNS name service. Then in that website I put index.html that explains "You ended on this site by using httpS instead of http, or the site you tried to reach does not exist (yet) or maybe the site's certificate is missing.".
    That 0000aaa.tld is not a magic name, it is just something that is first in alphabetic order of website names.
    Th0m likes this.
  6. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

    This is unrelated from your post, but yes, it's good to do this and make sure ISPConfig uses the cert for the web you created. I have not seen this in the perfect server tutorials though.

    I told you how to do this in #3 and Taleman in #5 aswell.
  7. DDArt

    DDArt Member

    Thank you all for the feedback/reply.
    The fix worked, by changing "all" sites to from ip bind to * instead. I will also use the @Taleman suggestion as well.
    It's been awhile since I have checked here and that's a good thing because this means that the panel is solid, just user-error or user-training.

Share This Page