Systemimager Error When Autoinstall

Discussion in 'HOWTO-Related Questions' started by asyadiqin, Jan 27, 2009.

  1. asyadiqin

    asyadiqin New Member

    I have installed Systemimager server and created a gloden client image successfully. However, I try to roll out a new machine (same model and spec as golden client), using the boot autoinstall CD, everything goes well until the part when it started the LVM initialiazation. Then it failed with some errors. I can try copying down the actually error if required.

    Below is the output of the partitions of the golden client machine

    Not sure if this could be a factor but both the golden client machine and the new client machine are DELL servers with hardware RAID running RAID1. FYI, both the golden client and systemimager server are running Fedora 10 (x86_64)

    Any help is greatly appreciated. Thanks.
    Last edited: Jan 27, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Do you remember the exact error message?
  3. asyadiqin

    asyadiqin New Member

    I've looked at the autoinstall script and the error occurs when it ran the following command

    which returns an error

    After that, it tried to initialize the LVM using pvcreate which gives the following error

    After the 2nd error, it stop all process and shows the GUI telling me the autoinstall has failed. I googled somewhere that the script could not find the dm-mod module to map the drive which in turn cause errors when initializing the LVM, but then what do I know. Anyway, hope you can help me with this.

    I have tried other possible solutions, eg. CloneZilla, Ghost4Linux, etc... but always had problems with installations.
    Last edited: Jan 28, 2009
  4. asyadiqin

    asyadiqin New Member

    Support For LVM Partition Type 8e

    I was looking at other solutions and found that most of them have issues with LVM partition type 8e. Not really sure what that means but could this be the cause?

    If so, is there a fix?

    I am also looking at PartImage. Maybe someone *hint* ;) could write a step-by-step howto on how to install PartImage on Fedora 10 preferably on a 64bit as most CPUs now support 64Bit.

    Thanks again.
  5. falko

    falko Super Moderator ISPConfig Developer

    I guess that all the imaging solutions you tried don't come with LVM support...
  6. asyadiqin

    asyadiqin New Member

    I'm not very familiar with Linux filesystem or partition, so I can't really say. All I know is that most other disk/partition clone solutions do have issues with LVM patition 8e but according to, SystemImager 4.1.4 fixed that but can't be sure. I really hope you can help sort this out for me. Thanks.
  7. falko

    falko Super Moderator ISPConfig Developer

    I don't think I can do much about this...
  8. asyadiqin

    asyadiqin New Member

    OK. Thanks anyway falko. I am now trying to use Systemimager 4.1.6 (Unstable) and see if this LVM issue is fixed in this version.

    Falko, are you familiar with Partimage? I managed to get that to work until the part where you get to the GUI to select the partition/disk to image and save to external server. Partimage cannot recognise the same partition, ie. /dev/sda2

    Or are you able to recommend me any alternatives to SystemImager that supports LVM2.
  9. falko

    falko Super Moderator ISPConfig Developer

    I last used it a few yeas ago - I might try it again and write a tutorial.

    If CloneZilla and Ghost4Linux aren't working for you, then no. :(

Share This Page