Testing BIND for DNS records [SOLVED]

Discussion in 'Installation/Configuration' started by Ark74, Feb 7, 2016.

  1. Ark74

    Ark74 Member

    I'm trying to figure out the way DNS works.
    I've follow some of the DNS guides here at HowtoForge, but i'm not really sure if i'm moving forward or if i still have issues.

    I've created the DNS Zone for the purchased domain, mydomain.com
    There on the records i've created ns1 and ns2, A records pointing to the server IP(v4).

    Active 	Type 	Name 		Data 		Priority 	TTL
    *	A 	mail 		0 	3600 	
    *	A 	ns1 		0 	86400 	
    *	A 	ns2 		0 	86400 	
    *	A 	mydomain.com. 		0 	3600 	
    *	A 	www 		0 	3600 	
    *	MX 	mydomain.com. 	mail.mydomain.com. 	10 	3600 	
    *	NS 	mydomain.com. 	ns1.mydomain.com. 	0 	3600 	
    *	NS 	mydomain.com. 	ns2.mydomain.com. 	0 	3600
    I've setup those as name servers from my dynadot control panel, AFAIK glue records for dynadot are name servers with a defined IP.

    Then use both ns1.mydomain.com and ns2.mydomain.com and dynadot say:
    "Your domain is using your hosting provider's name servers. All website settings and email services are configured through them."
    At this point i thought that i only needed to wait up to 24 hours but i'm around that mark and i see no change at all, then tried to ping BIND.

    Logged into my server and did,
    dig @localhost mydomain.com
    ; <<>> DiG 9.9.5-3ubuntu0.7-Ubuntu <<>> @localhost mydomain.com
    ; (2 servers found)
    ;; global options: +cmd
    ;; Got answer:
    ;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 45480
    ;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
    ; EDNS: version: 0, flags:; udp: 4096
    ;mydomain.com.        IN    A
    ;; Query time: 376 msec
    ;; SERVER: ::1#53(::1)
    ;; WHEN: Sat Feb 06 19:46:42 CST 2016
    ;; MSG SIZE  rcvd: 48
    I see a SERVFAIL and i think that it's bad news.
    Any advice?
  2. till

    till Super Moderator Staff Member ISPConfig Developer

  3. Ark74

    Ark74 Member

    Ok, i think i found my problem.
    Somewhere on my installation i forgot/skiped the line that asked to install bind. So i installed it *after* ISPConfig3 and now with this post, i see that's the root of my problems, the symptoms are explained there. My bad sorry, i though that i only needed to install and it will be all set.

    So i guess my question now is, are the steps described by @benlake apply for ISPConfig3?
    or how can i enable the bind plugin for ispconfig and don't screw what i have done so far?

    Thanks in advance and sorry again for skipping the bind install part.
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Run an ispconfig update and choose to reconfigure services during update. If the symlinks for the bind module and plugin are not there afterwards, then you can create it manually.
  5. Ark74

    Ark74 Member

    I've tried running the update script, but seems like i have the latest version so no update for me, nor the reconfiguration of the services.
    So i tried with this way,
    wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
    tar xfz ISPConfig-3-stable.tar.gz
    cd ispconfig3_install/install/
    php -q update.php
    based on what i found here.

    Run the update, made backups, and reconfigure the services and now DNS is working
    #named -g -p 53
    08-Feb-2016 09:28:18.301 managed-keys-zone: loaded serial 4
    08-Feb-2016 09:28:18.303 zone 0.in-addr.arpa/IN: loaded serial 1
    08-Feb-2016 09:28:18.307 zone 127.in-addr.arpa/IN: loaded serial 1
    08-Feb-2016 09:28:18.310 zone localhost/IN: loaded serial 2
    08-Feb-2016 09:28:18.314 zone 255.in-addr.arpa/IN: loaded serial 1
    08-Feb-2016 09:28:18.315 zone mydomain.com/IN: loaded serial 2016020802
    08-Feb-2016 09:28:18.315 all zones loaded
    08-Feb-2016 09:28:18.316 running
    08-Feb-2016 09:28:18.316 zone mydomain.com/IN: sending notifies (serial 2016020802)
    08-Feb-2016 09:28:18.321 client {some.ipv4.ip.here}#41692: received notify for zone 'mydomain.com'
    If i put the domain on my browser now it's found :)
    I'll check if everything is working as it should be, but right now DNS is working now hurray!

    Thank you very much :)

Share This Page