The Perfect Server on Ubuntu 20.04 (TESTED)

Discussion in 'Installation/Configuration' started by ustoopia, Apr 26, 2020.

  1. ustoopia

    ustoopia Member

    Hey everybody,


    Thought I might as well post my experience that I've had when I tried to install ISPconfig on a fresh Ubuntu 20.04 server. All went well! The server is up and running, and I haven't ran into any errors (yet?). I did however ran in to a couple minor things that I will mention below.
    I carefully followed every step from the guide for ISPconfig on Ubuntu 18.04 from this website (, and there are a couple of things that I had to do differently, but with the same end results.

    At the point where we install apache and php7.2 in the guide, change 7.2 in to 7.4 for all entries. Also I noticed that php-gettext and php7.4-recode packages could not be found. So I just skipped those. Of course the same thing counts for where you install php7.4-fpm and php7.4-opcache later on in the guide. Now since I have no idea what these two packages do exactly, I can not say if this might cause problems in the future. Also I did not yet look in to finding out a way to install these packages or a workaround or whatever. I'm curious if I even need to or not.

    Where we install jailkit 2.19 in the guide, change 2.19 in to version 2.21 and you're good.

    At step 7 in the guide this is mentioned : In case you get an error for thelast 'patch' command, then Ubuntu has probably fixed the issue in the meantime, so it should be safe to ignore that error then.
    I indeed got that the last patch error so I did not complete the patching. It all looked good to me.

    Considered that I followed every step from the 18.04 guide, and the tiny edits I had to make, do I now have a system that is ready for production? Or are there things included in the guide that I no longer had to perform and the fact that I did might cause problems later on?? Has anybody else tried to do the same thing also perhaps? And if so can you share if you learned any things that you could share with us?
    Last edited: Feb 14, 2021
    ahrasis likes this.
  2. BlueEagle

    BlueEagle New Member

    When i ran the tutorial for Ubuntu 20.04 for nginx I ran into an issue where it looked for ispconfig.sock in /var/lib/php7.2-fpm which does not exist. This resulted in a BAD GATEWAY error when attempting to open the ISP Config interface.

    To fix this I opened /tmp/ispconfig3*/install/dist/conf/ubutnu1804.conf.php and changed the lines
    $conf['nginx']['php_fpm_init_script'] = 'php7.2-fpm';
    $conf['nginx']['php_fpm_socket_dir'] = '/var/lib/php7.2-fpm';
    $conf['nginx']['php_fpm_init_script'] = 'php7.4-fpm';
    $conf['nginx']['php_fpm_socket_dir'] = '/var/lib/php7.4-fpm';
    the i ran 'php -q update.php' from the install directory of ispconfig having it reconfigure the services. That resulted in a working system.

    I have not tested, but you can likely make the above changes before the first install, and have it work on first go.
  3. till

    till Super Moderator Staff Member ISPConfig Developer

    ISPConfig does not support Ubuntu 20.04 yet, therefore it can not detect the PHP version used by Ubuntu 20.04. I recommend not setup and use ISPConfig on Ubuntu 20.04 for production servers until we adjusted the installer and tested it, there might be further issues due to the use of PHP 7.4 and also due to the use of the MariaDB version that ships with the new Ubuntu version. The next ISPConfig release 3.1.16 will contain support for Ubuntu 20.04.
  4. ustoopia

    ustoopia Member

    Thanks Till. For my production machine I will most definitely wait for the official release and guide.
  5. nhybgtvfr

    nhybgtvfr Well-Known Member HowtoForge Supporter

    haven't tested 20.04 with ispconfig myself yet, hope to get around to that this week, although I have had a quick look at 20.04.
    I've tested ispconfig3.1.15p3 on 18.04, only installing php7.4, and using MariaDB 10.4, I've tested with this quite extensively by now (including multi-server) and I've yet to encounter any issues. (well, there was in fact, 1 issue, but that was all my own fault doing something stupid and nothing to do with ispconfig, and/or server software/configuration)
    I used the ondrej repo's for php and apache, and those repo's are actually ahead of the default versions of both apache and php in ubuntu 20.04. apache 2.4.43 vs 2.4.41 (20.04) and php7.4.5 vs php7.4.3 (20.04). 20.04 also used MariaDB 10.3 by default.

    the only thing I needed to remember, was to change all the 7.2 path references to 7.4 in server-config - <server> - web - php settings.
    there's also one for the fastcgi php.ini path in the fastcgi tab, although I can't remember now if I actually needed to change that or if it picked up the right path automatically. and this would be fixed in the release that officially supports 20.04.

    so i'm confident that ispconfig won't have any issues with php7.4 as default.
    and as I've used the 20.04 default or newer versions of everything else (, albeit on 18.04, I don't foresee any problems.
    that said, I wouldn't look at putting 20.04 into production until I've done at least a couple of weeks testing, and ispconfig officially supports it. (i'd probably still end up modding it even then though, eg phpmyadmin 5.02 instead of 4.9.* that 20.04 uses)

    hopefully the new perfect server tutorial will get a bit more of a rewrite rather than a cut and paste to change version numbers, ie include rspamd as part of a new clean install, I think it should also include the install/config of the roundcube ispconfig plugins.
    I see little point in including how to install roundcube without actually tying roundcube into ispconfig. :)
    (i know that tutorials available separately, i just think a setup guide should be a complete, all-in-one, setup guide, and i'm sure a lot of ispconfig newcomers wouldn't even know about them otherwise)
    ahrasis and ustoopia like this.
  6. KalanVryce

    KalanVryce New Member

    Just out of curiosity is there any rough, possible guess, maybe kinda deal, on when 3.1.16 may be coming? Yes I realize that 20.04 has just been released and I used all of those synonyms with the understanding that I'm not looking for anything specific. I would like to spin up my 20.04 and get everything moved over but prefer to wait for the official thumbs up. Thanks in advance for your time for any answer including a "no".
  7. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    My guess is in a week or two or may be three because @till did say that he is testing both new Ubuntu and Centos versions.

    Those who are "ambitious and brave" may do the upgrading themselves, the best is of course on a test server, but could also be done on non commercial production server, simply because there is actually no real danger when I did such a thing during Ubuntu 18.04 release the last two years back before the official ISPConfig support and guide was released back then.

    When the official version of ISPConfig and its guide are released, one can always run through it one more time, just to be sure and safe, and update ISPConfig one more time.

    That said, I also haven't attempted the upgrade as I did before since I have been busy during this fasting month.
    ledufakademy likes this.
  8. Ryein

    Ryein New Member

    Cool, looking forward to using this on 20.04.
  9. wvh

    wvh New Member

    I, too, have been looking forward to doing a new install on Ubuntu 20.04. I have to deploy a new server and do not want to waste time installing Ubuntu 18. I am sure that whoever is working on it is busy, but I am getting desperate enough waiting that I may have to use the outdated version of Ubuntu. Any updates on a possible release date would be VERY much appreciated. TIA.
  10. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    What outdated version? Ubuntu 16.04 and 18.04 are still supported so they are not outdated.
    Install 18.04 now and dist-upgrade to 20.04 in August or September.
    ledufakademy and Th0m like this.
  11. wvh

    wvh New Member

    Perhaps "outdated" was the wrong term. "Older" would probably have been a better choice of words. I actually did attempt to do a dist-upgrade of a current install of Ubuntu 18 to 20.04 but it doesn't want to complete and I end up having to fall back to the previous version. I have had this issue in the past with major distro upgrades, which is why I prefer to do a new install from scratch.
  12. Taleman

    Taleman Well-Known Member HowtoForge Supporter

    Ubuntu 18.04 upgrade to 20.04 is going to be supported about the time when 20.04.1 is released, sometime in August is my guess. Then do-release-upgrade command should do the upgrade.
    But Ubuntu dist-upgrades have not been reliable enough to my liking. But I do not use Ubuntu on my own servers and desktops, I use Debian GNU/Linux. This may be just because Ubuntu does not publish detailed upgrade instructions. On Debian the dist-upgdades have worked well since Debian Project started, provided the upgrade instructions in Release Notes are followed.
  13. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    That's a fair comment from non-ubuntu user though as one of the users I'd say, on the other hand, that the Ubuntu upgrade is actually reliable.

    I planned to upgrade to the latest Ubuntu LTS soon after I finished making minor modifications to my copy of ISPConfig 3.1.15p3 to cover version 20.04 and will stay with it until official ISPConfig supports it.

    It's true one could be waiting until August before getting the official supports for Ubuntu 20.04 but it could be any time earlier too, so only do it if your servers aren't commercial servers and you don't need an immediate official support from here.
  14. Ryein

    Ryein New Member

    I think the point release was already released by Canonical?
  15. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    ISPConfig haven't supported this version of Ubuntu yet and that is the most important part. So waiting is still the best for most of us.
  16. till

    till Super Moderator Staff Member ISPConfig Developer

  17. mikekgr

    mikekgr New Member

    Dear Sir, what is the expected release date for official Ubuntu server 20.04 support? I am in the way to setup a new 20.04 server and I like to have ispconfig in it. Thanks for your fine work.

    Best Regards.
  18. Th0m

    Th0m ISPConfig Developer Staff Member ISPConfig Developer

  19. mikekgr

    mikekgr New Member

  20. TonyG

    TonyG Active Member

    This is my very first experience with ISPConfig.
    I took a chance and installed a completely new Ubuntu 20.04. Then went through the Perfect setup using 3.1.15p3, accommodating for PHP 7.4 and a couple other points as noted by the OP. I was not successful. I only minimally tried to diagnose the errors because I understand we should wait for 3.1.16, but I was successful. Here are my notes in addition to those cited by the OP.

    Apache error.log reports the following:

    "python_init: Python version mismatch, expected '2.7.17', found '2.7.18rc1'."

    "python_init: Python executable found ''." << that one is weird. There is no executable in the single quotes. I didn't know what to do about this. stop/start of apache didn't help. A server restart actually did clear this error. More on this below.

    "mod_fcgid: error reading data from FastCGI server"
    I got this and other issues that were leading to PHP 7.2 dependencies. I added ondrej's repo and did an update but that didn't help. It seemed that php7.2-cgi was not installed. I installed that one package and finally got something other than server error 500 in the browser. The error.log now seemed to indicate there were other PHP modules missing like mysqli. I re-did the Perfect instruction for installing PHP, did a final apt upgrade again, and restarted.

    That finally got me to a ISPConfig login.

    The first page generation was VERY slow, but I got a page after about 20 seconds with no errors. I suspect there was some init process running. After this there have been no page load delays.

    The error.log again reported the Python version mismatch and no executable found.
    I created a symbolic link, 'python' in /usr/bin to /usr/bin/python2.7. I did this after setting 'alias' in various places failed.
    After an apache restart it finally saw the executable.

    It looks like I have a good installation. I will not do anything serious until 3.1.16x officially claims support. I would be fine with a complete re-installation of OS and ISPConfig given how much I messed with the PHP and Python in this system.

    As noted in another thread, the only thing I don't have working are certs. I can deal with this.

Share This Page