The Perfect Server tutorial needs update (Ubuntu 16.04)?

Discussion in 'HOWTO-Related Questions' started by uniQ, Jul 7, 2016.

  1. uniQ

    uniQ New Member

    I just tried to install a server with Ubuntu 16.04 and ISPConfig 3.1b2 following this tutorial:

    Sadly, I can't get phpmyadmin and webmail to work. phpmyadmin shows plain text in browser and webmail just 404's.
    I already ensured that mod_php is installed and rechecked all commands for php7 from the tutorial but it just won't work. :/

    Some people from the comments section have encountered the same problems and suggested that the tutorial might need an update and/or more testing.
    Maybe some of you already found a workaround for those problems I mentioned?

    Thanks in advance. :)

    EDIT: Also tested this with Debian Stretch and got the same results.
    Last edited: Jul 8, 2016
    montero92 likes this.
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    phpmyadmin works fine here on my copy of the guide. I guess you accidently tried to access it on port 8080 instead of port 80. Remove :8080 from the url and try to access it again. Same for webmail.

    The link to phpmyadmin and webmail in ispconfig is configurable, ensure that you enter the full url of the installation location of phpmyadmin and webmail there.
    montero92 likes this.
  3. uniQ

    uniQ New Member

    Thanks for the hint! I will give this a shot later and report here.
    If this was the problem, where should I configure the URLs in ISPConfig? :)
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    System > Interface config
    uniQ likes this.
  5. uniQ

    uniQ New Member

    Confirmed. It works! Thanks for your help. ;)
  6. uniQ

    uniQ New Member

    Alright, phpmyadmin and webmailer seem to work properly now but I ran into another problem now:
    Websites running with PHP-FPM or HHVM are not interpreted. Like with phpmyadmin before, all I get is plain text. Fast-CGI is the only option that works atm. Is there something I was missing?

    Currently running on Debian stretch, PHP7, Apache2 btw
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you install mod_fastcgi as described in the tutorial? The step is in the php-fpm install part if I remember correctly.
  8. uniQ

    uniQ New Member

    Hmm, double checked and this package was not installed indeed, since I forgot to add 'contrib non-free' to the sources.list.
    However, the problem remains even after installing the package. Website still opens with text on FPM and HHVM:

    * Front to the WordPress application. [...]

    Could this have caused some configuration issue during the server setup?
    Oh and thanks again for your help. Really appreciated. :)

    EDIT: Just had to enable it, FPM and HHVM work like a charm! :D
    Last edited: Jul 8, 2016
  9. uniQ

    uniQ New Member

    Sorry to nag again, but there is a minor issue I can't seem to fix by myself.
    I created a letsencrypt certificate for ISPConfig and successfully secured the webinterface with it. Problem is, when I access phpmyadmin through ISPConfig now, it automatically assumes that the connection should be https:// - and Google Chrome for instance quits with an error message saying that the communitation couldn't be trusted.
    Accessing phpmyadmin via Incognito mode and http:// works perfectly, but it's a bit clumsy not being able to use the ISPConfig shortcuts.
    Any ideas on this? :/
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The phpmyadmin url is completely configurable, so if its http or https is set by you. if the url starts with http://, then it is http, if it starts with https://, then its https.
  11. uniQ

    uniQ New Member

    I tried setting the URL to http:// for phpmyadmin but the link still redirects to https:// - don't know if this has to do with Google Chrome, but it's not working for me. :/

    Attached Files:

  12. uniQ

    uniQ New Member

    Well, I found a workaround for this problem.
    The reason for this behaviour was enabled HSTS in the ISPConfig vhost. I manually disabled it in 000-ispconfig.vhost (Header always add Strict-Transport-Security "max-age=0"), restarted apache2 and now the links are working.

    Would love to see native options for ISPConfig encryption via Letsencrypt in the future. :)

    EDIT: Seems like ISPConfig sets HSTS off for websites by default and on for itself. I feel like it should be the other way around. :D
    Last edited: Jul 12, 2016
    montero92 likes this.
  13. Brianjes

    Brianjes New Member

    Can someone please update this tutorial to use Nginx instead of Apache?
    Thank you
  14. Morons

    Morons Member

    Had the same Issue, on Ubuntu
    apt remove --purge phpmyadmin //the answer to remove the phpmyadmin database is irrelevent for this scenario
    apt install phpmyadmin // NOTE: mane sure you select apache2 or whatever - <<
    now the default link in IPSConfig databases will work with the url set to /phpmyadmin

Share This Page