The Perfect Setup - Ubuntu 6.10 Server Question

Discussion in 'HOWTO-Related Questions' started by n74jw, Nov 6, 2006.

  1. n74jw

    n74jw New Member


    I am trying out "The Perfect Setup" for Ubuntu 6.10 server. I am not using the official server-version of Ubuntu but the standard Edgy desktop. All things have been going well thus far. I am not a complete Ubuntu novice, but Bind is something I have never been able to get to work properly. Apparently Bind is biting me in the ass here as well.

    My first issue started on step 10, when I was running the command.

    chown -R bind:bind /var/lib/named/var/*

    The directory did not exist. I changed the second var before the /* to dev and the command completed properly.

    The issue became more apparent when I restarted Bind and checked the syslog and found numerous errors, basically indicated Bind did not start.


    Nov 6 16:15:13 barf named[3719]: found 1 CPU, using 1 worker thread
    Nov 6 16:15:13 barf named[3719]: loading configuration from '/etc/bind/named.conf'
    Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: change directory to '/var/cache/bind' failed: file not found
    Nov 6 16:15:14 barf named[3719]: /etc/bind/named.conf.options:2: parsing failed
    Nov 6 16:15:14 barf named[3719]: loading configuration: file not found
    Nov 6 16:15:14 barf named[3719]: exiting (due to fatal error)

    I went on and tried to install mysql, which I also have poor track record.

    The second issue was after setting the sql root password, running this command.

    mysqldadmin -h <FQDN> -u root password <password>

    The result was 'Lost connection to mysql server during query'. So I tried the computer's IP address in place of FQDN, and all with the same result. This is where I stopped. I need to fix my DNS/Bind settings, but have no clue on how to go about doing that. There is a DNS server already on the LAN, servicing the same zone. I am hoping Ubuntu could replace that machine. Could that be an issue? I cannot see whom my Ubuntu server is using for DNS either.

    Any help would be great, thanks...

  2. falko

    falko Super Moderator ISPConfig Developer

    Did you install BIND like this?
    apt-get install bind9
    What's the output of
    netstat -tap
  3. r0ydster

    r0ydster New Member


    Falko, just wanted to say thanks for the guide. I had no problems with my server installation when following the the guide.

    I also used the perfect setup guide for 5.10, and had no issues with that guide as well.

    Thanks again for this great resource and keep up the good work!

  4. PrawnStar

    PrawnStar New Member

    I also got the first problem and found it was due to the pid file being stored inside the chroot...

    If you are having this problem then try setting dirs/files up like this:

    drwxr-xr-x 2 bind bind 4096 Dec 12 01:56 /var/lib/named/var/run/bind/run/
    [email protected]:/etc/bind# ls -l /var/lib/named/var/run/bind/run/
    total 4
    -rw-r--r-- 1 bind bind 6 Dec 12 01:56

    It worked for me, and now I'm going to bed :)

    p.s. not sure about the mysql problem
  5. GiuseppeConlon

    GiuseppeConlon New Member

    I too am having the same bind error as OP though I did not have the trouble with /var/lib/named/var/ not existing.

    I installed bind using:

    apt-get install bind9
    As for, it does not exist on my system.

    Any help is appreciated, thanks.
  6. PrawnStar

    PrawnStar New Member won't exist until bind has been started. It hold the Process ID of the bind daemon.

    Have a look for the processes running:
    # ps -ef | grep named

    if this doesn't return anything then you should try to start it:
    # /etc/init.d/bind9 start

    watch for errors:
    # tail -n 100 /var/log/syslog

    If it doesn't start you should hopefully get some nice messages telling you why.

Share This Page