this fixed my errors

Discussion in 'Installation/Configuration' started by Boon-Dog-Danny, Aug 28, 2006.

  1. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    I had been thru so many versions trying to get my website working right I almost gave up.. my stuff was built using php4.. all I had was errors.. this or that.. something was failing .. I asked Falko what was the best setup using php4.. he replied Debian 3.1.. My Mission!

    ok first falkos perfect setup.. Debian 3.1.. trust me on this.. why? when so many newer versions are out.. can we say php5? let me tell you what php5 runs.. NOTHING!! :mad: well thats not true.. it does run stuff it just dont do it correctly .. most programs were and still are being made using php4.. and darn it if its made in php4.. it just dont do well on the php5 stuff.. as a noob to linux.. I found suse installed easy.. but was like cracking a safe trying to get yast to update or add php4.. never did get the yast search deal working.. :confused: worked on that for a few weeks.. so quick review..trying to add php4 after install when php5 is installed= night-f-ing mare.. dont go there..its not pretty. :cool:

    so .. New to linux? dont know what you need for your website /mail/ basic site stuff.. throw the other stuff out and start here..

    first..this link is dead.. get this file by searching google.. organ u has it.. debian-31r0a-i386-netinst.iso..make sure this part 31r0a is in the search results.. get that iso and burn a bootable copy.. then its pretty much follow the steps.. until.. you'll notice near the end Our friend Falko kinda lets us drift a bit.. otherwise the thing is a work of art..anyway so when you get to the mail part and it asks.. are you ready for manual setup.. choose no.. it will go to auto and do all the crap itself.. .. ok but then it gets a bit tricky.. ispconfig.. I noticed when I would get to this part..on most setups.. i'd get about halfway and it would fail saying could not find this or wrong php.. just a bunch of different errors...and if I did get it working stuff would fail.. the webmail was a nightmare.. work? work? did anyone ever get it working?.. so.. here is what I did.. and my stuff is running as smooth as silk.. I followed the directions in perfect setup.. and isp would fail.. and then it dawned on ;) its the version.. I looked at the date falko did the setup.. back in like 3 of 05.. so I went to ispconfig and searched for older versions...ahh.. the oldest is 2.0.4.. its like from 6/05.. i grabbed that.. and omg call dixie and slap me silly.. first.. i think newer versions of isp jams up if you dont use php5.. (I still dont see any reason to include php5 in anything.. it sucks and nothing runs right on it..) the older version uses and is more compatable with the php4 hence it installs with no trouble what so ever.. and .. guess what.. in fifty different setup.. using all different types,, suse.. debian..cento.fedora.. the dang webmail always failed.. I always had to use pop mail.. using this version.. everything works mail.. all my programs.. so if your having trouble.. keywords.. debian3.1/ispconfig 2.0.4

    now im sure there are 50 better ways.. but this worked for me, and its easy-button way..

    so thats my two cents
  2. till

    till Super Moderator Staff Member ISPConfig Developer


    the latest ISPConfig 2.2.6 runs perfectly on the debian sarge setup without the need to install anything that is not installed by the perfect setup guide, i installed it about a week ago.

  3. fobicodam

    fobicodam ISPConfig Developer ISPConfig Developer

    I ve always installed it on fedoras 4/5, with php4/5, always runs ok.. except known issues...

    PHP5 comes with a lot of security options disabled by default when they were enabled on PHP4, you just need to modify the config file to enable them.. applications dont see the diference..
  4. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    I disagree about the php5.. it works.. some..php5 does not like any stuff I run.. it really dont like my arcade or downloads area.. it runs the public part.. the admin parts are done..

    Hey Falko.. here is a strange deal.. the first time I installed the Debian 3.1.. I followed the perfect setup and it went really close to what you showed..
    So I start doing my host server.. ok I'm at the beginning and it asks user.. and then passwords.. THEN... (the part I always had trouble with.. the configure the host part). it says.. configure internet access w/o dchp..I'm like what?? never seen that.. never even seen the option.. so I am like ..lets try it.. yes.. it pops into a screen that looks like the suse10.1 setup when your doing the host setup stuff.. and asks.. ip.. netmask.. gateway.. nameservers then poped back into the setup .. I did not have to mess with the host file or config the stuff.... very handy doing it that way..

    on the new ispconfig.. I can get the thing to install.. I just have trouble with it working after words.. the mail never works when I try the new version..
  5. falko

    falko Super Moderator ISPConfig Developer

    I guess you don't have a DHCP server in your network. No problem.

    Just enter the details that you would have entered on page 3 of the Perfect Setup in /etc/network/interfaces.

    What's the exact problem? What's in the mail log?
  6. Boon-Dog-Danny

    Boon-Dog-Danny New Member

    well I got it working.. the mail.. but first.. the setup part.. I do have a DHCP server.. I setup suse10.1 on this machine before.. it had DHCP stuff.. it works.. dont get me wrong..just never seen that.. very easy..

    ok back to the mail trouble.. I noticed when I got logged in if i send a letter i have to change the from and reply to info.. it has [email protected] instead of [email protected] and when i changed it.. it changes back.. anyway to keep it changed?

    and thanks Falko the debian 3.1 advice works great, better then the suse..
  7. falko

    falko Super Moderator ISPConfig Developer

    You mean in webmail? Which webmail do you use? If it's RoundCube: that seems to be a bit buggy as it's still in alpha or beta stage...

Share This Page