This IP address is shared.

Discussion in 'Installation/Configuration' started by willebanks, Jul 7, 2006.

  1. willebanks

    willebanks New Member

    Well I'm back...and with a new set of trouble...
    I was able to setup a new site (thanks again for the push in the right direction) and all seemed well until I tried to get to the main url. I received an IP shared error...?

    I can still get to
    and even
    but not
    I didn't bother trying the second URL as it's still parked with GoDaddy

    I did do a search of the forums to see if anyone else had this problem and maybe the solution as well but came up here I am again!

    Any help will be appreciated as always!

  2. till

    till Super Moderator Staff Member ISPConfig Developer

    If you get the shared IP page, you selected the wrong IP for your website. If you are behind a router, you must select your internal IP for the website, not the external IP.
  3. n1kol1s

    n1kol1s New Member

    what i dir was i setup my routers remote conection to listen in port 8080 so when i type my godady url www.example.cpm:8080 i get my router web intrface. that means the domain is working. then i setup a static ip for my server box and i fowoard the following ports 80 , 443 , 21
    you set up the dmz zone to point to your server box but it opens all ports and thats not a good idea.
    hope that helped.
  4. willebanks

    willebanks New Member

    hey everyone,

    I think I just caused more problems for myself then was necessary! My main domain name was still being served by Yahoo! and I was having a hard time figuring out the settings to change to get everything to work properly and after much frustration and many hours wasted I transfered the Domain to godaddy as I also have an account with them. Yahoo is being prissy about losing the domain and now not providing me with a authorization code so I can finalize the transfer.

    So nothing is pointing to my IP, so nothing not even email is comming in!

    Anyway I checked all the settings on my router...made sure that was the DMZ and that all applicable ports were pointing to that address...not sure what else I can do...oddly I can still connect to ISPConfig and webmail by using the and address...https of course! Shared ip still comes up if I try http or my static ip

    not sure what else to try?
    Last edited: Jul 9, 2006
  5. n1kol1s

    n1kol1s New Member

    This IP address is shared. For access to the web site which you look for, enter its address instead of its IP.
    Manualy add this URL in your hosts file. For WindowsXP users this file is located here C:\WINDOWS\system32\drivers\etc\hosts.file Open the hosts.file with notepad and add the following line: Save and then right click your network status icon on the bottom right of your screen and Repair your connection. This will flush your dns cache and then you can type to your web browser. Alternatively you can run ipconfig /flushdns in your Command Prompt.
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Did you select your internal IP in ISPConfig for this website?
  7. Ovidiu

    Ovidiu Active Member

    same problem here:

    for one of my domains I get the shared IP page displayed, although the domain is pointed to my server and the domain has been correctly been set up in ispconfig. vhost entries are ok, bind entries are ok too, so where could the problem be? the site does point to my server but instead of pointing to /var/www/web5 it points to /var/www/sharedip
  8. till

    till Super Moderator Staff Member ISPConfig Developer

    Is your server in a NAT enviroment behind a router?
  9. Ovidiu

    Ovidiu Active Member

    no it is a server from strato, the thing is I am currently moving my sites from one server to another, and I did also change the dns values where this particular domain: was pointing to to the new IP address.

    so: DNS changed, files and folders copied, permissions set, vhost exists, bind entry exists, still pointing to shared ip - any clues?
  10. till

    till Super Moderator Staff Member ISPConfig Developer

    The shared IP error always occurs when the DNS point to another IP then the IP you selected for the website in ISPConfig.

    Please make sure that the IP you selected is really correct, you can try to change any value in the website, e.g. quota and hit save to tell ISPConfig to update the configuration again.
  11. Ovidiu

    Ovidiu Active Member

    ok try a dns test yourself: the result for should be this:

    this is the DNS server I maintain for this domain. the entry of /etc/bind/ is this:

    I do not see any errors...
  12. till

    till Super Moderator Staff Member ISPConfig Developer

    I'am getting here (over telekom backbone): =>
  13. Ovidiu

    Ovidiu Active Member

    ok, than that is still a propagation problem although I changed the DNS entry yesterday, maybe at the same time?

    I will get back with this problem tomorrow? it should not persist after tomorrow...

    do you have any clues about this problem?

    what do you get for a dig ? if you also get the same old IP, it might be the same kind of problem except for the debian-syst-maint access problem to mysql.

    a big thx to you
  14. Ovidiu

    Ovidiu Active Member

    ok, problem is still here: shows me a shared IP page (a dig should lead here:
    the site is configured and should point to /var/www/web5 not to /var/www/sharedip

    any ideas whats wrong? should I delete and recreate the site? its actually empty so I can do that.
  15. till

    till Super Moderator Staff Member ISPConfig Developer

    No. From my location everything is fine. If I enter in the browser, I get the welcome page of the website and not the shared IP page.

Share This Page