Totally Confused DNS!

Discussion in 'Installation/Configuration' started by skeeta, Aug 27, 2005.

  1. skeeta

    skeeta New Member

    I ran the "perfect" setup for Fedora 4 & installed ISPConfig following the instructions to the letter (I previously did both but messed it up so I reformatted and reinstalled everything - Quicker in the long run for me).

    I have only one publically available Static IP (ADSL modem/router) and a 4 port hub. My network is setup using static ips and my DNS server is authorative for my domain and is located on my network. The server is named "www" with A records for "mail", "ftp", "ns1" & "ns2" (yeah I know I should do that). From within my network I can ping all fqdn's.

    I can now no longer send or receive e-mails and my webpage is not accessible outside of my local network (these I have using my primary/secondary dns).

    When I try to send email within my network I get "Host or domain name not found. Name service error for type=A: Host found but no data record of requested type"

    When I try to send externally (using Hotmail for testing) I get "Unable to deliver message to the following recipients, due to being unable to
    connect successfully to the destination mail server."

    Using to perform various checks portions of the report state

    1) "Error: At least one of your MX records points to an IP address that is not a public IP. The problem IP(s) are: is not a public IP
    Note that these IPs are not reachable, which can cause extra resource usage, slight mail delays, and possibly bounced mail."

    2) Error: At least one of your WWW IPs is not a public IP. The problem IP(s) are: is not a public IP
    That means that some or all people trying to get to your web site will not be able to get there.

    I have manually tried to correct these dns entries but seem to be getting nowhere.


    Your help will be gladly received :D
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    What did you mean with manually corrected?

    Open the ISPCONFIG controlpanel, go to the DNS-Manager, open the primary DNS-Record for your Domain, replace the IP with your public IP Address and replace the IP from the www A-Record also with your public IP address. Then configure your router that connections on port 80 are forwarded to IP: and SMTP connections are forwarded to IP:

    But one question: Why do you use two internal IP's on your server, when you only have one static IP that can be forwarded?
  3. skeeta

    skeeta New Member

    Thanks for your quick response and help.

    I can now send them with no problem and the outside world can find my mail server but emails are returned with "Relay access denied" error.

    That's got to be a simple setting somewhere no!
  4. till

    till Super Moderator Staff Member ISPConfig Developer

    Are returned from where? When you try to send an email? Please post the exact error message.
  5. skeeta

    skeeta New Member

    Sorry if I wasn't clear.
    The problem is encountered when sending out via my own isp email account.
    Complete error message is

    This is the Postfix program at host

    I'm sorry to have to inform you that your message could not be
    be delivered to one or more recipients. It's attached below.

    For further assistance, please send mail to <postmaster>

    If you do so, please include this problem report. You can
    delete your own text from the attached returned message.

    The Postfix program

    <[email protected]>: host[] said: 554
    <[email protected]>: Relay access denied (in reply to RCPT TO
  6. till

    till Super Moderator Staff Member ISPConfig Developer

    Is the domain: in your local-host-names file? The location
    of the file depends on your linux distro, mostly it is in the /etc/postfix/ directory.

Share This Page