Trouble Compiling 2.6.28 in Kubunutu 8.04

Discussion in 'Kernel Questions' started by Sahrjd, Feb 16, 2009.

  1. Sahrjd

    Sahrjd New Member

    I am attempting to configure, compile and install the 2.6.28 kernel on my Dell D610 Laptop which is currentlly running Kubuntu 8.04, 2.6.24-23 generic.

    I was following the tutorial "How To Compile A Kernel - The Ubuntu Way" and was cruising along fine until page 2, step 6. The trouble started with the command "fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers" I followed the advice listed in this thread and avoided typing the fakeroot line verbatim from the tutorial but apparentlly that wasn't enough to keep me ont he right road. What I typed was "sudo fakeroot make-kpkg --initrd --append-to-version=-linux-2.6.28-custom".

    There was alot of stuff that scrolled by but the two indicators that I was no longer cruising along but was in fact off the road where:

    1) It compelted after about 20 seconds and I believe compiling the kernel takes a bit longer then that.

    2) The last output to the terminal was "exec debian/rules APPEND_TO_VERSION=-linux-2.6.28-custom INITRD=YES
    nothing to be done."

    I would be happy to provide the entire termianl output that followed the command "sudo fakeroot make-kpkg --initrd --append-to-version=-linux-2.6.28-custom" if anyone beleives that would help.

    If the solution to this issue is already out there on the forum I apoloize. I missed it in my search and I would welcome someone simply directing me to it.
    Last edited: Feb 16, 2009
  2. falko

    falko Super Moderator ISPConfig Developer

    Can you try this?
    cd /usr/src/linux
    make clean && make mrproper
    cp /boot/config-`uname -r` ./.config
    make menuconfig
    make-kpkg clean
    fakeroot make-kpkg --initrd --append-to-version=-custom kernel_image kernel_headers
  3. Sahrjd

    Sahrjd New Member

    For some reasont he command "sudo cp /boot/config-`uname -r` ./.config" is returning the message "cp: cannot stat '/boot/config-uname -r': No such file or directory".

    I have run through the entire How To twice now and never had issues with that command.

    I knwo I could go on without it but I really don't want to config the kernel and miss something essential.

    Any ideas what I may have done wrong?
  4. falko

    falko Super Moderator ISPConfig Developer

    What are the outputs of
    uname -r
    ls -la /boot/
  5. Sahrjd

    Sahrjd New Member

    upgraded from 8.04 to 8.10 last night.

    Now my wireless networking (802.11 or GSM) no longer work. I will trywired when I get home tonight.

    I will try get the output you asked for tonight and post it here.
    Last edited: Feb 18, 2009
  6. Sahrjd

    Sahrjd New Member

    Wierd....I upgraded from 8.04 to 8.10 via 802.11 wireless. Now non of my network connections work (802.11, GSM, or wired). I am not usign static IPs. I will look around and once I get this resolved get back to the kernel compiling.
  7. falko

    falko Super Moderator ISPConfig Developer

    What's in /etc/network/interfaces? Have you tried to configure your network connections in NetworkManager?
  8. Sahrjd

    Sahrjd New Member

    I think that network manager is the issue.

    I was able to get wired ethernet working via the command: sudo dhclient eth0.

    I was able to get wireless (802.11) working via the command: sudo dhclient wlan0

    funny thing is wireless never asked for my password for the router (it could have been cached or included in my keyring).

    the GSM (Auto Mobile Broadband) will not work though. I am working on that right now. I am using a Sierra Wireless USBConnect Mercury card and got it workign in 8.04 but now no worky.
    Last edited: Feb 20, 2009
  9. Sahrjd

    Sahrjd New Member

    Clearly a Network Manager issue...other had similar issues after upgrading from 8.04 to 8.10. Additionally I can connect by using the tutorial provided by Sierra Wireless.

    When I complete all the steps in the tutorial then issue the command pppd call gsm885 in a terminal it connect fine, I am issued and ip and I can work as long as I leave that terminal window alone. Network Manager still says I am disconnected but both Opera and Firefox work and I can use the package manager to down load updates and I can ping people to my hearts content. :confused:
  10. Sahrjd

    Sahrjd New Member

    BTW, here are the answers to the below questions:

    2.6.27-11-generic (remember I just upgraded to 8.10 from 8.04)

    total 29904
    drwxr-xr-x 3 root root 4096 2009-02-18 07:19 .
    drwxr-xr-x 21 root root 4096 2009-02-18 07:19 ..
    -rw-r--r-- 1 root root 422838 2008-11-24 17:47 abi-2.6.24-22-generic
    -rw-r--r-- 1 root root 508385 2009-01-29 16:11 abi-2.6.27-11-generic
    -rw-r--r-- 1 root root 80062 2008-11-24 17:47 config-2.6.24-22-generic
    -rw-r--r-- 1 root root 91358 2009-01-29 16:11 config-2.6.27-11-generic
    drwxr-xr-x 2 root root 4096 2009-02-18 11:17 grub
    -rw-r--r-- 1 root root 7506752 2008-12-09 06:03 initrd.img-2.6.24-22-generic
    -rw-r--r-- 1 root root 7505925 2008-11-28 11:46 initrd.img-2.6.24-22-generic.bak
    -rw-r--r-- 1 root root 8153404 2009-02-18 07:15 initrd.img-2.6.27-11-generic
    -rw-r--r-- 1 root root 124152 2008-09-11 16:11 memtest86+.bin
    -rw-r--r-- 1 root root 905617 2008-11-24 17:47
    -rw-r--r-- 1 root root 1031799 2009-01-29 16:11
    -rw-r--r-- 1 root root 1074 2009-01-29 16:12 vmcoreinfo-2.6.27-11-generic
    -rw-r--r-- 1 root root 1921176 2008-11-24 17:47 vmlinuz-2.6.24-22-generic
    -rw-r--r-- 1 root root 2248912 2009-01-29 16:11 vmlinuz-2.6.27-11-generic
  11. falko

    falko Super Moderator ISPConfig Developer

    /boot/config-2.6.27-11-generic exists, so

    sudo cp /boot/config-`uname -r` ./.config
    sshould work.
  12. Sahrjd

    Sahrjd New Member

    uname -r now results in:


    I got wireless workignt thorugh GSM (AT&T USB Connect Mercury). THe GSM modem even started working under Network Mangler. Wired and 802.11 still would nto work.

    I went into the menu option System\Software Sources and checked the box by "Software restricted by copyright or legal issues (multiverse)
    under the Ubuntu Software tab and added and checked the box next to hardy main
    uder the Updates tab I checked the box next to Pre-release updated (Intrepid-proposed).

    After that I went to the menu option System\Update Manager and checked for updates and installed all it came up with.

    After that Opera would not run, Catalyst Control Center would not run, EnvyNG would not run, Network Mangler would not connect to anything.
    When I attemtp to run Opera, Cat Ctrl Cntr and EnvyNG from the console I get the message "Floating point exception".
  13. Sahrjd

    Sahrjd New Member

    The origional issue was simple. Everything worked the way I wanted other then I could nto use a set of USB headphones I wanted to use. So I was goignt o build, compile and install an updated Kernel and enable USB Audio or whatever that option is in the Kernel.

    Now I have just F'ed up the entire system.

    I am about to give up. I am looking at imaging the drive and just starting over. I am no Linux expert and it has taken me about 6 weeks to get everything set the way I want which is why I am not lookign forward to redoign all my settings.
  14. falko

    falko Super Moderator ISPConfig Developer

    If you want an imaging solution, take a look at SystemImager, CloneZilla, or Ghost4Linux (there are howtos for all three solutions here on HowtoForge).
  15. Sahrjd

    Sahrjd New Member

    Thanks for the suggestions. I am pretty sick right now and may wait until I return to work next week to work on the Linux partition again. The Win XP partition works fine so I can function for now.
  16. Sahrjd

    Sahrjd New Member


  17. Sahrjd

    Sahrjd New Member

    Giving up...imaging drive now...going to start over from scratch.

Share This Page