Trouble logging into server using FTP/SSH accounts created in ISPConfig

Discussion in 'Server Operation' started by L0ngb0@rd3r, Jun 18, 2017.

  1. L0ngb0@rd3r

    L0ngb0@rd3r New Member

    Currently I am running an Ubuntu 16.04 server on AWS to host my brothers and my website. I used this guide to help me set up and manage the server from ISPconfig. I am having trouble with getting FTP or SSH to work on it using the account logins I create from ISPconfig. To be clear, I am able to get a connection to the server but the server replies with the following in FileZilla:

    • Status: Disconnected from server
    • Status: Resolving address of
    • Status: Connecting to MYIPADDRESS:21...
    • Status: Connection established, waiting for welcome message...
    • Status: Initializing TLS...
    • Status: Verifying certificate...
    • Status: TLS connection established.
    • Command: USER username
    • Response: 331 User username OK. Password required
    • Command: 530 Login authentication failed
    • Error: Critical error: Could not connect to server
    In SSH I can see that the user is created and is listed in the /etc/passwd list. To me it seems as if the passwords are not being written to the database correctly or something. I'm pretty new to linux and ubuntu but I was hoping someone might be knowledgeable enough to work through this with me. I can't even change the standard wordpress login php file name which is a huge security risk. Please let me know what you think may be happening and how to fix. Thanks for any help you guys can provide.
  2. Tomislav Aurednik

    Tomislav Aurednik Member HowtoForge Supporter

    Your're using TLS for FTP? Have you set the port range and opened the ports in the firewall? Can't help you with SSH created with ISPConfig because I only use normal ssh for my server and don't allow client SSH.
    In filezilla I had the same error when I had the ports used for data transfer closed. It connected over port 21 got the certificate, verifyed it but then dropped the connection becouse it couldn't connect from one of the forts declared in my port range 50510:50610. Just added that to the firewall entry in ISPConfig and it worked.

Share This Page