trouble with wordpress and suPhp

Discussion in 'Installation/Configuration' started by Ovidiu, May 2, 2009.

  1. Ovidiu

    Ovidiu Active Member

    wordpress has placed this .htaccess inside my web folder and needs it:

    seems ok to me, at least it ran with ispcfg2
    now I get an 500 server error and the log file says:

    .htaccess: RewriteEngine not allowed here

    can't find much on this with google, I checked and the rewrite module is loaded with apache2.
    I tried adding this directive within the ispcfg3 administration ot this certain website but it didn't help:

  2. Ovidiu

    Ovidiu Active Member

    k, solved that. my syntax was a little wrong, this fixed it:

    now I get another 500 error and the log says:

    chmod -R 755 web/ helped here
  3. Ovidiu

    Ovidiu Active Member

    ok, seems I got it to run. how can I check if it is indeed running on suPhp?

    answered my own question, top says:

  4. Ovidiu

    Ovidiu Active Member

    ahhh! another problem!

    all of a sudden the site doesn't work anymore, I go back and find the default index.html that I deleted is back, thus preventing my index.php from working, then I get a 404 error and notice my .htacess file has been overwritten by an empty default one?

    is ispcfg restoring itsself? how could I prevent this?

Share This Page