Tutorial for installation ISPConfig 3.1 for CentOS

Discussion in 'Installation/Configuration' started by martinhe, Feb 9, 2021.

  1. martinhe

    martinhe Member

    i need update worked tutorials for CentOS 7.7
    1. For installation ISPConfig 3.1.15 (last v 3.1.x)
    2. For installation ISPConfig 3.2.2 (last v 3.2.x) too
    I found only old tutorial for 3.1. where is deprached certbot-auto: https://www.howtoforge.com/tutorial...php-pureftpd-postfix-dovecot-and-ispconfig/2/

    I do not want to install certbot via snap.
    I do not want use CentOS 8.

    On 3.1.15 i try this:
    mkdir /opt/certbot
    cd /opt/certbot
    wget https://dl.eff.org/certbot-auto
    chmod a+x ./certbot-auto
    Try #1 Replace certbot code for this:
    curl https://get.acme.sh | sh -s
    [root@centos ~]# acme.sh --version
    [root@centos ~]#
    Try #2 Replace certbot code for this:
    yum install certbot # from EPEL
    Try #3 Replace certbot code for this:
    # only remove (comment) cerbot, but 3.1.15 barely auto-detect for acme.sh does not working on 3.1.15
    #mkdir /opt/certbot
    #cd /opt/certbot
    #wget https://dl.eff.org/certbot-auto
    #chmod a+x ./certbot-auto
    But letsencrypt stay not working in my try cases #1, #2 and #3.

    Send me please actually worked tutorial for installation ISPConfig lastest 3.1 and lastest 3.2 on Centos 7.7
    Thanks you very much for advice.
    Last edited: Feb 9, 2021
  2. Steini86

    Steini86 Active Member

    Thats not an error message
    Why? That's the official method to install certbot-auto for centos: https://certbot.eff.org/lets-encrypt/centosrhel7-apache.html
    ISPC3.2 also supports centos8.

    Al your trys above should work. But without any error message, there is nothing I can do for you.
  3. martinhe

    martinhe Member

    My accesslog:
    <HOST> - - [09/Feb/2021:14:45:34 -0500] "GET /.well-known/acme-challenge/le-6022e65956104.txt HTTP/1.0" 200 329 "-" "-"
    <HOST> - - [09/Feb/2021:15:00:51 -0500] "GET / HTTP/1.1" 200 2199 "-" "Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/76.0.3809.71 Safari/537.36" 
    My browser:
    Websites prove their identities with certificates. Firefox cannot verify the valid.example server because the certificate used is not valid for it. Error code: MOZILLA_PKIX_ERROR_SELF_SIGNED_CERT  
    View certificate:
    acme working but no correctly.
    Do I happen to have to set something in the ISPConfig configuration?

    Why I don't want to use a snap is not important. I don't want to be persuaded to use it. Please take it for granted.
    Last edited: Feb 9, 2021
  4. Steini86

    Steini86 Active Member

    Last edited: Feb 9, 2021
  5. ahrasis

    ahrasis Well-Known Member HowtoForge Supporter

    Just ensure you have only one LE client and if you have installed others, ensure you have removed them cleanly. The first main test would be upon install or update you can successfully create LE SSL certs for the server.

    I don't think there'll be an update for Centos PST since the change of RHEL policy on relating it recently but I may be wrong, so do wait for the developer(s) to confirm on this.
  6. martinhe

    martinhe Member

    • Certbot from EPEL already works for me, I probably originally tested it badly. I tried again and it seems to work perfectly.
    • Acme.sh would certainly also work if I did not use the minimal installation, but filled in the advanced installation parameters.

      Thanks all for support.

Share This Page