typo3 6.2 ISPconfig Multidomain aliasdomain

Discussion in 'General' started by geraldm, Jul 16, 2014.

  1. geraldm

    geraldm New Member


    I have on the server installation with TYPO3 running uaf Debian 7.5 with nginx.
    now I want an additional domain / site manage in the Typo3 instance.

    I'm placing an alias to give the domain and target domain to. if I have the domain dan established in Typo3 I get the error 500, nor anywhere else in the error log is a hint.

    When I use the alias domain to a different domain in a left without Typo3 it goes. Now I have this installation already done in other severn x times. Everything was great, just with ISPconfig I do not get out there.

    What do I need to alias domain and otherwise adjust to make it work?

    'm perplexed.

    Thanks a lot
  2. till

    till Super Moderator Staff Member ISPConfig Developer

    In ispconfig you just have to add a aliasdomain. A 500 error is most likely a php error, check the error.log of the website to find out why typo3 throws this error.
  3. geraldm

    geraldm New Member

    Hello Till,

    Many thanks for your reply.
    I have in the error.log of the domain and also from Nginx but looked as no entries are written when calling.

    Therefore, I'm also a bit perplexed. I've tested it with 2 sepperaten and installations on different servers. Even with a Basic installation of 6.2 (sample project).
    maybe I'm doing something trivial wrong.
    What should I consider when creating the alias domain?

    Thanks a lot
  4. geraldm

    geraldm New Member

    Hello Till, and all others

    I have absolutely no idea where I can still look. it is not writing error. It does not work with different servers and installations of ISPConfig, Typo3 Multi Domain. I put the alias domains on a Joomla, WordPress or other installation, it works. Tests I multidomain Typo3 on a host other things with nginx no ISP, it works.

    I'm really at a loss. The only certainty is that small. Who can help me please, has an idea?

    Thanks a lot
    Last edited: Jul 22, 2014
  5. geraldm

    geraldm New Member

    I do not get it

    With all the looking I have just changed times by hand in the domain.tld.vhost the position of the alias domain.

    of: server_name master_domain.tld alias_domain.tld;

    to: server_name alias_domain.tld master_domain.tld;

    And now comes the alias domain. but all the behind not come.

    Means: When I work with Typo3 and alias domains is always the first entry in the "server_name".

    Does anyone have any idea where the fault lies?

    Many Thanks
  6. geraldm

    geraldm New Member

    problem solved, new security settings on nginx and Typo3

    problem solved, new security settings on nginx and Typo3
  7. till

    till Super Moderator Staff Member ISPConfig Developer

    Thank you for posting the solution!
  8. geraldm

    geraldm New Member


    Hello Till thank you for your note.

    now I can say more accurate, as it now also works reproducible.

    Apparently can Typo3 and sometimes nginx not the "server_name" variable from the ". Vhost" Read. At the "apache" is it straightforward.

    If this is the case, you have to adjust the variable in the Install Tool. also the version should be checked by nginx and adjusted if necessary.

    In realURL still use the usual adjustments.

    See also:


    nice evening
    Last edited: Jul 24, 2014

Share This Page