Ubuntu 11.04 boot cycles through USB devices

Discussion in 'Server Operation' started by DantePasquale, Aug 18, 2014.

  1. DantePasquale

    DantePasquale Member HowtoForge Supporter


    I'm having an issue with a Ubuntu 11.04 server that won't boot up completely.

    It discovers a couple of USB devices (keyboard and mouse).

    Then seems to time-out and re-discovers the same 2 USB devices.

    Any ideas on how to debug this? I tried disabling USB from BIOS (HP DL 360 g7) but then no keyboard so it wouldn't boot from the Ubuntu menu ;(

    Also, the hard drive is encrypted and I don't know how to boot up on a USB stick, mount the luks files to edit them and possibly black-list the USB devices to see if I can get it to boot.

    Anyone know how to do this?
  2. srijan

    srijan New Member HowtoForge Supporter

    Use this tutorial to make the USB bootable.

    I am aware of such situation and I have solved it before as follows.
    1 Created 12.04 USB boot
    2 after USB booting install crypsetup
    3 Mount the encrypted harddisk as
    where xvdc will be your internal hardisk and xxxx will be your password/passphrase of encrypted harddisk.

    then further you can mount the harddisk manually with any drive or it is also mounted in /media/some_long_name of the hard-disk.
  3. srijan

    srijan New Member HowtoForge Supporter

    In addition to that, you need to check the /boot of mounted hardisk for boot failures. :)

Share This Page